CVE-2022-4729: Graphite Web Template Name cross site scripting
A vulnerability was found in Graphite Web and classified as problematic. This issue affects some unknown processing of the component Template Name Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The name of the patch is 2f178f490e10efc03cd1d27c72f64ecab224eb23. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-216743.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.0.2+ - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.4-5ubuntu0.1 - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-1ubuntu0.22.04.1 - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 0.9.12+ - Upgrade
Upgrade
ubuntu/graphite-webto a version that resolves this vulnerability.Fixed in 0.9.15+ - Upgrade
Upgrade
debian/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-2Fixed in 1.1.10-8Fixed in 1.2.1~pre2-1 - Upgrade
Upgrade
debian/graphite-webto a version that resolves this vulnerability.Fixed in 1.1.8-1.1 - Upgrade
Upgrade
Graphite Webto a version that resolves this vulnerability.Patch 2f178f490e10efc03cd1d27c72f64ecab224eb23
Event History
Frequently Asked Questions
What is the severity of CVE-2022-4729?
CVE-2022-4729 is classified as a problematic vulnerability that can lead to cross-site scripting.
How do I fix CVE-2022-4729?
To fix CVE-2022-4729, upgrade Graphite Web to the recommended versions specific to your Ubuntu or Debian distribution.
Which versions of Graphite Web are affected by CVE-2022-4729?
CVE-2022-4729 affects Graphite Web versions prior to 1.0.2+, 1.1.4-5ubuntu0.1, 1.1.8-1ubuntu0.22.04.1, 0.9.12+, and 0.9.15+ among others.
Is remote exploitation possible with CVE-2022-4729?
Yes, remote exploitation of CVE-2022-4729 is possible since the vulnerability can be triggered remotely.
What component is primarily affected by CVE-2022-4729?
CVE-2022-4729 primarily affects the Template Name Handler component of Graphite Web.