CWE
476
Advisory Published
Updated

CVE-2022-4842: Null Pointer Dereference

First published: Mon Aug 15 2022(Updated: )

A flaw NULL Pointer Dereference in the Linux kernel NTFS3 driver function attr_punch_hole() was found. A local user could use this flaw to crash the system.

Credit: secalert@redhat.com secalert@redhat.com

Affected SoftwareAffected VersionHow to fix
Linux Linux kernel=6.2-rc1
redhat/Linux kernel<6.2
6.2
ubuntu/linux<5.15.0-70.77
5.15.0-70.77
ubuntu/linux<5.19.0-42.43
5.19.0-42.43
ubuntu/linux<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-allwinner<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-allwinner-5.19<5.19.0-1012.12~22.04.1
5.19.0-1012.12~22.04.1
ubuntu/linux-allwinner-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws<5.15.0-1034.38
5.15.0-1034.38
ubuntu/linux-aws<5.19.0-1025.26
5.19.0-1025.26
ubuntu/linux-aws<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-5.0<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-5.15<5.15.0-1034.38~20.04.1
5.15.0-1034.38~20.04.1
ubuntu/linux-aws-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-fips<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-aws-hwe<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure<5.15.0-1036.43
5.15.0-1036.43
ubuntu/linux-azure<5.19.0-1026.29
5.19.0-1026.29
ubuntu/linux-azure<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-4.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-5.15<5.15.0-1036.43~20.04.1
5.15.0-1036.43~20.04.1
ubuntu/linux-azure-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-5.19<5.19.0-1026.29~22.04.1
5.19.0-1026.29~22.04.1
ubuntu/linux-azure-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-edge<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-fde<5.15.0-1036.43.1
5.15.0-1036.43.1
ubuntu/linux-azure-fde<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-fde-5.15<5.15.0-1036.43~20.04.1.1
5.15.0-1036.43~20.04.1.1
ubuntu/linux-azure-fde-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-fde-5.19<5.19.0-1026.29~22.04.1
5.19.0-1026.29~22.04.1
ubuntu/linux-azure-fde-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-azure-fips<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-bluefield<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-dell300x<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-fips<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp<5.15.0-1032.40
5.15.0-1032.40
ubuntu/linux-gcp<5.19.0-1024.26
5.19.0-1024.26
ubuntu/linux-gcp<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-4.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-5.15<5.15.0-1032.40~20.04.1
5.15.0-1032.40~20.04.1
ubuntu/linux-gcp-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-5.19<5.19.0-1024.26~22.04.1
5.19.0-1024.26~22.04.1
ubuntu/linux-gcp-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gcp-fips<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gke<5.15.0-1031.36
5.15.0-1031.36
ubuntu/linux-gke<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gke-4.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gke-5.0<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gke-5.15<5.15.0-1031.36~20.04.1
5.15.0-1031.36~20.04.1
ubuntu/linux-gke-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gke-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gkeop<5.15.0-1018.23
5.15.0-1018.23
ubuntu/linux-gkeop<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gkeop-5.15<5.15.0-1018.23~20.04.1
5.15.0-1018.23~20.04.1
ubuntu/linux-gkeop-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-gkeop-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-hwe<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-hwe-5.15<5.15.0-70.77~20.04.1
5.15.0-70.77~20.04.1
ubuntu/linux-hwe-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-hwe-5.19<5.19.0-42.43~22.04.1
5.19.0-42.43~22.04.1
ubuntu/linux-hwe-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-hwe-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-hwe-edge<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-ibm<5.15.0-1028.31
5.15.0-1028.31
ubuntu/linux-ibm<5.19.0-1022.24
5.19.0-1022.24
ubuntu/linux-ibm<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-ibm-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-ibm-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-intel<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-intel-5.13<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-intel-iotg<5.15.0-1028.33
5.15.0-1028.33
ubuntu/linux-intel-iotg<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-intel-iotg-5.15<5.15.0-1030.35~20.04.1
5.15.0-1030.35~20.04.1
ubuntu/linux-intel-iotg-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-iot<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-kvm<5.15.0-1031.36
5.15.0-1031.36
ubuntu/linux-kvm<5.19.0-1023.24
5.19.0-1023.24
ubuntu/linux-kvm<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-laptop<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-lowlatency<5.15.0-70.77
5.15.0-70.77
ubuntu/linux-lowlatency<5.19.0-1024.25
5.19.0-1024.25
ubuntu/linux-lowlatency<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-lowlatency-hwe-5.15<5.15.0-70.77~20.04.1
5.15.0-70.77~20.04.1
ubuntu/linux-lowlatency-hwe-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-lowlatency-hwe-5.19<5.19.0-1024.25~22.04.1
5.19.0-1024.25~22.04.1
ubuntu/linux-lowlatency-hwe-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-lowlatency-hwe-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-lts-xenial<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-nvidia<5.15.0-1023.23
5.15.0-1023.23
ubuntu/linux-nvidia<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-nvidia-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-5.10<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-5.14<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-5.17<5.17.0-1034.35
5.17.0-1034.35
ubuntu/linux-oem-5.17<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-5.6<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-6.0<6.0.0-1019.19
6.0.0-1019.19
ubuntu/linux-oem-6.0<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-6.1<6.1.0-1008.8
6.1.0-1008.8
ubuntu/linux-oem-6.1<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-6.8<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oem-osp1<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle<5.15.0-1033.39
5.15.0-1033.39
ubuntu/linux-oracle<5.19.0-1023.26
5.19.0-1023.26
ubuntu/linux-oracle<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle-5.0<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle-5.13<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle-5.15<5.15.0-1033.39~20.04.1
5.15.0-1033.39~20.04.1
ubuntu/linux-oracle-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-oracle-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-raspi<5.15.0-1027.29
5.15.0-1027.29
ubuntu/linux-raspi<5.19.0-1018.25
5.19.0-1018.25
ubuntu/linux-raspi<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-raspi-5.4<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-raspi2<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-riscv<5.19.0-1018.19
5.19.0-1018.19
ubuntu/linux-riscv<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-riscv-5.15<5.15.0-1031.35~20.04.1
5.15.0-1031.35~20.04.1
ubuntu/linux-riscv-5.15<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-riscv-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-snapdragon<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-starfive<6.2.0-1002.2
6.2.0-1002.2
ubuntu/linux-starfive<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-starfive-5.19<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-starfive-6.5<6.2~<5.15.90
6.2~
5.15.90
ubuntu/linux-xilinx-zynqmp<6.2~<5.15.90
6.2~
5.15.90
debian/linux
5.10.218-1
6.1.94-1
6.1.90-1
6.9.8-1
6.9.9-1

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203