CVE-2022-48468: Integer Overflow
protobuf-c before 1.4.1 has an unsigned integer overflow in parserequiredmember.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/libsignal-protocol-cto a version that resolves this vulnerability.Fixed in 2.3.3-3Fixed in 2.3.3-6Fixed in 2.3.3-6.1 - Upgrade
Upgrade
debian/protobuf-cto a version that resolves this vulnerability.Fixed in 1.4.1-1Fixed in 1.5.1-1 - Upgrade
Upgrade
debian/libsignal-protocol-cto a version that resolves this vulnerability.Fixed in 2.3.3-3 - Upgrade
Upgrade
debian/protobuf-cto a version that resolves this vulnerability.Fixed in 1.4.1-1 - Upgrade
Upgrade
protobuf-cto a version that resolves this vulnerability.Fixed in 1.4.1
Event History
Frequently Asked Questions
What is the severity of CVE-2022-48468?
CVE-2022-48468 is classified as having a moderate severity due to the potential for an unsigned integer overflow.
How do I fix CVE-2022-48468?
To fix CVE-2022-48468, upgrade to protobuf-c version 1.4.1 or later.
Which software is affected by CVE-2022-48468?
CVE-2022-48468 affects protobuf-c versions prior to 1.4.1 as well as specific versions of IBM QRadar SIEM and IBM QRadar Incident Forensics.
What type of vulnerability is CVE-2022-48468?
CVE-2022-48468 is an unsigned integer overflow vulnerability.
Is CVE-2022-48468 exploitable remotely?
CVE-2022-48468 may be exploitable remotely, depending on how the vulnerable software is integrated and deployed.