CVE-2023-0461: Use-after-free vulnerability in the Linux Kernel

Published Feb 23, 2023
·
Updated

A use-after-free flaw was found in the Linux kernel’s TLS protocol functionality in how a user installs a tls context (struct tlscontext) on a connected TCP socket. This flaw allows a local user to crash or potentially escalate their privileges on the system.

Other sources

NVD description: There is a use-after-free vulnerability in the Linux Kernel which can be exploited to achieve local privilege escalation. To reach the vulnerability kernel configuration flag CONFIGTLS or CONFIGXFRMESPINTCP has to be configured, but the operation does not require any privilege. There is a use-after-free bug of icskulpdata of a struct inetconnectionsock. When CONFIGTLS is enabled, user can install a tls context (struct tlscontext) on a connected tcp socket. The context is not cleared if this socket is disconnected and reused as a listener. If a new socket is created from the listener, the context is inherited and vulnerable. The setsockopt TCPULP operation does not require any privilege.

Upstream commit: https://github.com/torvalds/linux/commit/2c02d41d71f90a5168391b6a5f2954112ba2307c

— Red Hat

There is a use-after-free vulnerability in the Linux Kernel which can be exploited to achieve local privilege escalation. To reach the vulnerability kernel configuration flag CONFIGTLS or CONFIGXFRMESPINTCP has to be configured, but the operation does not require any privilege. There is a use-after-free bug of icskulpdata of a struct inetconnectionsock. When CONFIGTLS is enabled, user can install a tls context (struct tlscontext) on a connected tcp socket. The context is not cleared if this socket is disconnected and reused as a listener. If a new socket is created from the listener, the context is inherited and vulnerable. The setsockopt TCPULP operation does not require any privilege. We recommend upgrading past commit 2c02d41d71f90a5168391b6a5f2954112ba2307c

— Ubuntu

Affected Software

23 affected componentsFixes available
redhat/kernel-rt<0:4.18.0-477.10.1.rt7.274.el8_8
0:4.18.0-477.10.1.rt7.274.el8_8
redhat/kernel<0:4.18.0-477.10.1.el8_8
0:4.18.0-477.10.1.el8_8
redhat/kernel<0:4.18.0-147.83.1.el8_1
0:4.18.0-147.83.1.el8_1
redhat/kernel<0:4.18.0-193.109.1.el8_2
0:4.18.0-193.109.1.el8_2
redhat/kernel-rt<0:4.18.0-193.109.1.rt13.160.el8_2
0:4.18.0-193.109.1.rt13.160.el8_2
redhat/kernel-rt<0:4.18.0-305.86.2.rt7.160.el8_4
0:4.18.0-305.86.2.rt7.160.el8_4
redhat/kernel<0:4.18.0-305.86.2.el8_4
0:4.18.0-305.86.2.el8_4
redhat/kernel<0:4.18.0-372.52.1.el8_6
0:4.18.0-372.52.1.el8_6
redhat/kernel<0:5.14.0-284.11.1.el9_2
0:5.14.0-284.11.1.el9_2
redhat/kernel-rt<0:5.14.0-284.11.1.rt14.296.el9_2
0:5.14.0-284.11.1.rt14.296.el9_2
redhat/kernel<0:5.14.0-70.58.1.el9_0
0:5.14.0-70.58.1.el9_0
redhat/kernel-rt<0:5.14.0-70.58.1.rt21.129.el9_0
0:5.14.0-70.58.1.rt21.129.el9_0
Linux Linux kernel>=4.13.0<4.14.303
Linux Linux kernel>=4.19<4.19.270
Linux Linux kernel>=5.4<5.4.229
Linux Linux kernel>=5.10<5.10.163
Linux Linux kernel>=5.15<5.15.88
Linux Linux kernel>=6.0<6.0.19
Linux Linux kernel>=6.1<6.1.5
Linux Linux kernel=6.2-rc1
Linux Linux kernel=6.2-rc2
redhat/kernel<6.2
6.2
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-477.10.1.rt7.274.el8_8
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-477.10.1.el8_8
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-147.83.1.el8_1
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-193.109.1.el8_2
  5. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-193.109.1.rt13.160.el8_2
  6. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-305.86.2.rt7.160.el8_4
  7. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-305.86.2.el8_4
  8. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-372.52.1.el8_6
  9. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-284.11.1.el9_2
  10. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-284.11.1.rt14.296.el9_2
  11. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-70.58.1.el9_0
  12. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:5.14.0-70.58.1.rt21.129.el9_0
  13. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.2
  14. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  15. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Patch 2c02d41d71f90a5168391b6a5f2954112ba2307c
  16. Configuration

    Blacklist the tls kernel module to prevent it from loading automatically.

    Linux kernel module loader tls module loading = blacklisted

Event History

Feb 22, 2023
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Feb 28, 2023
CVE Published
via MITRE·02:23 PM
Data Sourced
via MITRE·02:23 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Mar 7, 2023
Data Sourced
via Red Hat·03:49 PM
DescriptionSeverityAffected Software
Aug 3, 2025
Exploit Published
via GitHub·08:12 AM

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2023-0461?

CVE-2023-0461 is classified as a high-severity vulnerability due to its potential for privilege escalation.

2

How do I fix CVE-2023-0461?

To fix CVE-2023-0461, update your Linux kernel to version 4.18.0-477.10.1.rt7.274.el8_8 or later.

3

Which Linux kernel versions are affected by CVE-2023-0461?

CVE-2023-0461 affects Linux kernel versions prior to 4.18.0-477.10.1.rt7.274.el8_8.

4

Can CVE-2023-0461 be exploited remotely?

CVE-2023-0461 primarily allows local users to exploit the vulnerability, rather than being remotely exploitable.

5

What impact does CVE-2023-0461 have on system integrity?

CVE-2023-0461 can cause system crashes and potentially allow local users to escalate their privileges on the system.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203