CWE
416 362
Advisory Published
Updated

CVE-2023-0590: Use After Free

First published: Tue Oct 18 2022(Updated: )

A use-after-free flaw was found in qdisc_graft in net/sched/sch_api.c in the Linux Kernel due to a race problem. This flaw leads to a denial of service issue. If patch ebda44da44f6 ("net: sched: fix race condition in qdisc_graft()") not applied yet, then kernel could be affected.

Credit: secalert@redhat.com secalert@redhat.com secalert@redhat.com

Affected SoftwareAffected VersionHow to fix
redhat/kernel<0:4.18.0-372.75.1.el8_6
0:4.18.0-372.75.1.el8_6
redhat/kernel<0:5.14.0-284.11.1.el9_2
0:5.14.0-284.11.1.el9_2
redhat/kernel-rt<0:5.14.0-284.11.1.rt14.296.el9_2
0:5.14.0-284.11.1.rt14.296.el9_2
Linux Linux kernel<6.1
Linux Linux kernel=6.1-rc1
redhat/Linux kernel<6.1
6.1
IBM QRadar SIEM<=7.5 - 7.5.0 UP8 IF01
ubuntu/linux<5.4.0-156.173
5.4.0-156.173
ubuntu/linux<5.15.0-60.66
5.15.0-60.66
ubuntu/linux<5.19.0-31.32
5.19.0-31.32
ubuntu/linux<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-allwinner<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-allwinner-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws<5.4.0-1107.115
5.4.0-1107.115
ubuntu/linux-aws<5.15.0-1030.34
5.15.0-1030.34
ubuntu/linux-aws<5.19.0-1019.20
5.19.0-1019.20
ubuntu/linux-aws<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-5.0<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-5.15<5.15.0-1030.34~20.04.1
5.15.0-1030.34~20.04.1
ubuntu/linux-aws-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-5.4<5.4.0-1107.115~18.04.1
5.4.0-1107.115~18.04.1
ubuntu/linux-aws-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-fips<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-aws-hwe<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure<5.4.0-1114.120
5.4.0-1114.120
ubuntu/linux-azure<5.15.0-1033.40
5.15.0-1033.40
ubuntu/linux-azure<5.19.0-1020.21
5.19.0-1020.21
ubuntu/linux-azure<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-4.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-5.15<5.15.0-1033.40~20.04.1
5.15.0-1033.40~20.04.1
ubuntu/linux-azure-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-5.4<5.4.0-1113.119~18.04.1
5.4.0-1113.119~18.04.1
ubuntu/linux-azure-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-edge<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-fde<5.15.0-1033.40.1
5.15.0-1033.40.1
ubuntu/linux-azure-fde<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-fde-5.15<5.15.0-1033.40~20.04.1.1
5.15.0-1033.40~20.04.1.1
ubuntu/linux-azure-fde-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-fde-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-azure-fips<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-bluefield<5.4.0-1068.74
5.4.0-1068.74
ubuntu/linux-bluefield<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-dell300x<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-fips<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp<5.4.0-1110.119
5.4.0-1110.119
ubuntu/linux-gcp<5.15.0-1029.36
5.15.0-1029.36
ubuntu/linux-gcp<5.19.0-1017.19
5.19.0-1017.19
ubuntu/linux-gcp<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-4.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-5.15<5.15.0-1029.36~20.04.1
5.15.0-1029.36~20.04.1
ubuntu/linux-gcp-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-5.4<5.4.0-1110.119~18.04.1
5.4.0-1110.119~18.04.1
ubuntu/linux-gcp-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gcp-fips<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gke<5.4.0-1105.112
5.4.0-1105.112
ubuntu/linux-gke<5.15.0-1027.32
5.15.0-1027.32
ubuntu/linux-gke<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gke-4.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gke-5.0<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gke-5.15<5.15.0-1027.32~20.04.1
5.15.0-1027.32~20.04.1
ubuntu/linux-gke-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gke-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gkeop<5.4.0-1074.78
5.4.0-1074.78
ubuntu/linux-gkeop<5.15.0-1015.19
5.15.0-1015.19
ubuntu/linux-gkeop<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gkeop-5.15<5.15.0-1015.19~20.04.1
5.15.0-1015.19~20.04.1
ubuntu/linux-gkeop-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-gkeop-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-hwe<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-hwe-5.15<5.15.0-60.66~20.04.1
5.15.0-60.66~20.04.1
ubuntu/linux-hwe-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-hwe-5.19<5.19.0-32.33~22.04.1
5.19.0-32.33~22.04.1
ubuntu/linux-hwe-5.4<5.4.0-156.173~18.04.1
5.4.0-156.173~18.04.1
ubuntu/linux-hwe-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-hwe-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-hwe-edge<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-ibm<5.4.0-1054.59
5.4.0-1054.59
ubuntu/linux-ibm<5.15.0-1025.28
5.15.0-1025.28
ubuntu/linux-ibm<5.19.0-1017.19
5.19.0-1017.19
ubuntu/linux-ibm<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-ibm-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-ibm-5.4<5.4.0-1054.59~18.04.1
5.4.0-1054.59~18.04.1
ubuntu/linux-ibm-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-intel<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-intel-5.13<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-intel-iotg<5.15.0-1025.30
5.15.0-1025.30
ubuntu/linux-intel-iotg<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-intel-iotg-5.15<5.15.0-1025.30~20.04.1
5.15.0-1025.30~20.04.1
ubuntu/linux-intel-iotg-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-iot<5.4.0-1019.20
5.4.0-1019.20
ubuntu/linux-iot<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-kvm<5.4.0-1096.102
5.4.0-1096.102
ubuntu/linux-kvm<5.15.0-1028.33
5.15.0-1028.33
ubuntu/linux-kvm<5.19.0-1018.19
5.19.0-1018.19
ubuntu/linux-kvm<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-laptop<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-lowlatency<5.15.0-60.66
5.15.0-60.66
ubuntu/linux-lowlatency<5.19.0-1017.18
5.19.0-1017.18
ubuntu/linux-lowlatency<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-lowlatency-hwe-5.15<5.15.0-60.66~20.04.1
5.15.0-60.66~20.04.1
ubuntu/linux-lowlatency-hwe-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-lowlatency-hwe-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-lowlatency-hwe-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-lts-xenial<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-nvidia<5.15.0-1017.17
5.15.0-1017.17
ubuntu/linux-nvidia<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-nvidia-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-5.10<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-5.14<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-5.17<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-5.6<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-6.0<6.0.0-1008.8
6.0.0-1008.8
ubuntu/linux-oem-6.0<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-6.1<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-6.8<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oem-osp1<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle<5.4.0-1106.115
5.4.0-1106.115
ubuntu/linux-oracle<5.15.0-1029.35
5.15.0-1029.35
ubuntu/linux-oracle<5.19.0-1017.20
5.19.0-1017.20
ubuntu/linux-oracle<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle-5.0<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle-5.13<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle-5.15<5.15.0-1029.35~20.04.1
5.15.0-1029.35~20.04.1
ubuntu/linux-oracle-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle-5.4<5.4.0-1106.115~18.04.1
5.4.0-1106.115~18.04.1
ubuntu/linux-oracle-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-oracle-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-raspi<5.4.0-1091.102
5.4.0-1091.102
ubuntu/linux-raspi<5.15.0-1024.26
5.15.0-1024.26
ubuntu/linux-raspi<5.19.0-1013.20
5.19.0-1013.20
ubuntu/linux-raspi<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-raspi-5.4<5.4.0-1091.102~18.04.1
5.4.0-1091.102~18.04.1
ubuntu/linux-raspi-5.4<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-raspi2<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-riscv<5.19.0-1013.14
5.19.0-1013.14
ubuntu/linux-riscv<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-riscv-5.15<5.15.0-1029.33~20.04.1
5.15.0-1029.33~20.04.1
ubuntu/linux-riscv-5.15<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-riscv-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-snapdragon<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-starfive<6.2.0-1002.2
6.2.0-1002.2
ubuntu/linux-starfive<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-starfive-5.19<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-starfive-6.5<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
ubuntu/linux-xilinx-zynqmp<5.4.0-1027.31
5.4.0-1027.31
ubuntu/linux-xilinx-zynqmp<6.1~<5.4.240<5.15.76
6.1~
5.4.240
5.15.76
debian/linux
5.10.218-1
6.1.94-1
6.1.90-1
6.9.7-1
6.9.8-1

Remedy

Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Reference Links

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203