CVE-2023-1945: Medium severity Mozilla Thunderbird vulnerability
Last updated 24 July 2024
Other sources
Unexpected data returned from the Safe Browsing API could have led to memory corruption and a potentially exploitable crash.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 115.14.0esr-1~deb11u1Fixed in 128.3.0esr-1~deb11u2Fixed in 115.14.0esr-1~deb12u1Fixed in 128.3.0esr-1~deb12u1Fixed in 115.15.0esr-1Fixed in 128.3.0esr-2 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:115.12.0-1~deb11u1Fixed in 1:115.15.0-1~deb11u1Fixed in 1:115.12.0-1~deb12u1Fixed in 1:115.15.0-1~deb12u1Fixed in 1:128.2.0esr-1Fixed in 1:128.3.0esr-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 102.10 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 102.10
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is CVE-2023-1945?
CVE-2023-1945 is a vulnerability that could have led to memory corruption and a potentially exploitable crash in Thunderbird and Firefox ESR.
Which software versions are affected by CVE-2023-1945?
Thunderbird versions prior to 102.10 and Firefox ESR versions prior to 102.10 are affected by CVE-2023-1945.
How severe is CVE-2023-1945?
CVE-2023-1945 has a severity rating of medium.
How can I fix the CVE-2023-1945 vulnerability in Thunderbird?
To fix the CVE-2023-1945 vulnerability in Thunderbird, update to version 102.10 or higher.
How can I fix the CVE-2023-1945 vulnerability in Firefox ESR?
To fix the CVE-2023-1945 vulnerability in Firefox ESR, update to version 102.10 or higher.