7.5
CWE
617
Advisory Published
CVE Published
Advisory Published
Updated

CVE-2023-2156: (0Day) Linux Kernel IPv6 RPL Protocol Reachable Assertion Denial-of-Service Vulnerability

First published: Mon May 08 2023(Updated: )

A flaw was found in the networking subsystem of the Linux kernel within the handling of the RPL protocol. This issue results from the lack of proper handling of user-supplied data, which can lead to an assertion failure. This may allow an unauthenticated remote attacker to create a denial of service condition on the system.

Credit: secalert@redhat.com secalert@redhat.com secalert@redhat.com

Affected SoftwareAffected VersionHow to fix
Linux Linux kernel
Redhat Enterprise Linux=9.0
Fedoraproject Fedora=38
Linux kernel
Linux Linux kernel>=5.7<5.10.184
Linux Linux kernel>=5.11<5.15.117
Linux Linux kernel>=5.16<6.1.34
Linux Linux kernel>=6.2<6.2.13
Linux Linux kernel>=6.3<6.3.8
Debian Debian Linux=10.0
redhat/kernel<6.2.13
6.2.13
ubuntu/linux<5.15.0-86.96
5.15.0-86.96
ubuntu/linux<6.2.0-34.34
6.2.0-34.34
ubuntu/linux<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-allwinner<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-allwinner-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws<5.15.0-1047.52
5.15.0-1047.52
ubuntu/linux-aws<6.2.0-1013.13
6.2.0-1013.13
ubuntu/linux-aws<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-5.0<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-5.15<5.15.0-1047.52~20.04.1
5.15.0-1047.52~20.04.1
ubuntu/linux-aws-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-6.2<6.2.0-1013.13~22.04.1
6.2.0-1013.13~22.04.1
ubuntu/linux-aws-6.2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-fips<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-aws-hwe<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure<5.15.0-1049.56
5.15.0-1049.56
ubuntu/linux-azure<6.2.0-1014.14
6.2.0-1014.14
ubuntu/linux-azure<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-4.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-5.15<5.15.0-1049.56~20.04.1
5.15.0-1049.56~20.04.1
ubuntu/linux-azure-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-6.2<6.2.0-1014.14~22.04.1
6.2.0-1014.14~22.04.1
ubuntu/linux-azure-6.2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-edge<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-fde<5.15.0-1049.56.1
5.15.0-1049.56.1
ubuntu/linux-azure-fde<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-fde-5.15<5.15.0-1049.56~20.04.1.1
5.15.0-1049.56~20.04.1.1
ubuntu/linux-azure-fde-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-fde-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-fde-6.2<6.2.0-1014.14~22.04.1.1
6.2.0-1014.14~22.04.1.1
ubuntu/linux-azure-fde-6.2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-azure-fips<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-bluefield<5.15.0-1027.29
5.15.0-1027.29
ubuntu/linux-bluefield<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-dell300x<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-fips<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp<5.15.0-1044.52
5.15.0-1044.52
ubuntu/linux-gcp<6.2.0-1016.18
6.2.0-1016.18
ubuntu/linux-gcp<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-4.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-5.15<5.15.0-1044.52~20.04.1
5.15.0-1044.52~20.04.1
ubuntu/linux-gcp-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-6.2<6.2.0-1016.18~22.04.1
6.2.0-1016.18~22.04.1
ubuntu/linux-gcp-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gcp-fips<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gke<5.15.0-1044.49
5.15.0-1044.49
ubuntu/linux-gke<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gke-4.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gke-5.0<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gke-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gke-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gkeop<5.15.0-1030.35
5.15.0-1030.35
ubuntu/linux-gkeop<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gkeop-5.15<5.15.0-1030.35~20.04.1
5.15.0-1030.35~20.04.1
ubuntu/linux-gkeop-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-gkeop-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe-5.15<5.15.0-86.96~20.04.1
5.15.0-86.96~20.04.1
ubuntu/linux-hwe-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe-6.2<6.2.0-34.34~22.04.1
6.2.0-34.34~22.04.1
ubuntu/linux-hwe-6.2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-hwe-edge<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-ibm<5.15.0-1040.43
5.15.0-1040.43
ubuntu/linux-ibm<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-ibm-5.15<5.15.0-1040.43~20.04.1
5.15.0-1040.43~20.04.1
ubuntu/linux-ibm-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-ibm-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-intel<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-intel-5.13<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-intel-iotg<5.15.0-1043.49
5.15.0-1043.49
ubuntu/linux-intel-iotg<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-intel-iotg-5.15<5.15.0-1043.49~20.04.1
5.15.0-1043.49~20.04.1
ubuntu/linux-intel-iotg-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-iot<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-kvm<5.15.0-1044.49
5.15.0-1044.49
ubuntu/linux-kvm<6.2.0-1014.14
6.2.0-1014.14
ubuntu/linux-kvm<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-laptop<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lowlatency<5.15.0-86.95
5.15.0-86.95
ubuntu/linux-lowlatency<6.2.0-1014.14
6.2.0-1014.14
ubuntu/linux-lowlatency<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lowlatency-hwe-5.15<5.15.0-86.95~20.04.1
5.15.0-86.95~20.04.1
ubuntu/linux-lowlatency-hwe-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lowlatency-hwe-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lowlatency-hwe-6.2<6.2.0-1014.14~22.04.1
6.2.0-1014.14~22.04.1
ubuntu/linux-lowlatency-hwe-6.2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lowlatency-hwe-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-lts-xenial<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-nvidia<5.15.0-1037.37
5.15.0-1037.37
ubuntu/linux-nvidia<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-nvidia-6.2<6.2.0-1011.11
6.2.0-1011.11
ubuntu/linux-nvidia-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-5.10<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-5.14<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-5.17<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-5.6<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-6.0<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-6.1<6.1.0-1016.16
6.1.0-1016.16
ubuntu/linux-oem-6.1<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-6.8<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oem-osp1<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle<5.15.0-1045.51
5.15.0-1045.51
ubuntu/linux-oracle<6.2.0-1013.13
6.2.0-1013.13
ubuntu/linux-oracle<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle-5.0<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle-5.13<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle-5.15<5.15.0-1045.51~20.04.1
5.15.0-1045.51~20.04.1
ubuntu/linux-oracle-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-oracle-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-raspi<5.15.0-1040.43
5.15.0-1040.43
ubuntu/linux-raspi<6.2.0-1014.16
6.2.0-1014.16
ubuntu/linux-raspi<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-raspi-5.4<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-raspi2<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-riscv<6.2.0-34.34.1
6.2.0-34.34.1
ubuntu/linux-riscv<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-riscv-5.15<5.15.0-1043.47~20.04.1
5.15.0-1043.47~20.04.1
ubuntu/linux-riscv-5.15<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-riscv-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-snapdragon<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-starfive<6.2.0-1006.7
6.2.0-1006.7
ubuntu/linux-starfive<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-starfive-5.19<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-starfive-6.5<6.4~<5.15.117
6.4~
5.15.117
ubuntu/linux-xilinx-zynqmp<5.15.0-1025.29
5.15.0-1025.29
ubuntu/linux-xilinx-zynqmp<6.4~<5.15.117
6.4~
5.15.117
debian/linux
5.10.218-1
5.10.221-1
6.1.94-1
6.1.99-1
6.9.8-1
6.9.9-1

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Reference Links

Parent vulnerabilities

(Appears in the following advisories)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203