Advisory Published


First published: Tue Jul 18 2023(Updated: )

This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22505 was introduced in version 8.0.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to latest version. If you're unable to upgrade to latest, upgrade to one of these fixed versions: 8.3.2, 8.4.0. See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html).|https://confluence.atlassian.com/doc/confluence-release-notes-327.html).] You can download the latest version of Confluence Data Center & Server from the download center ([https://www.atlassian.com/software/confluence/download-archives).|https://www.atlassian.com/software/confluence/download-archives).] This vulnerability was discovered by a private user and reported via our Bug Bounty program.

Credit: security@atlassian.com security@atlassian.com

Affected SoftwareAffected VersionHow to fix
Atlassian Confluence Data Center>=8.0.0<8.3.2
Atlassian Confluence Server>=8.0.0<8.3.2

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2023-22505?

    CVE-2023-22505 is a high severity Remote Code Execution (RCE) vulnerability in Confluence Data Center & Server.

  • How does CVE-2023-22505 affect Confluence Data Center & Server?

    CVE-2023-22505 affects Confluence Data Center & Server versions 8.0.0 to 8.3.2.

  • What is the severity score of CVE-2023-22505?

    CVE-2023-22505 has a CVSS Score of 8, indicating a high severity.

  • What can an authenticated attacker do with CVE-2023-22505?

    An authenticated attacker can execute arbitrary code using CVE-2023-22505.

  • How can I fix CVE-2023-22505?

    To fix CVE-2023-22505, upgrade Confluence Data Center & Server to a version beyond 8.3.2.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203