Advisory Published


First published: Tue Jul 18 2023(Updated: )

This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22508 was introduced in version 7.4.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to latest version. If you're unable to upgrade to latest, upgrade to this fixed version: 8.2.0. See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html|https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Data Center & Server from the download center ([https://www.atlassian.com/software/confluence/download-archives|https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was discovered by a private user and reported via our Bug Bounty program.

Credit: security@atlassian.com security@atlassian.com

Affected SoftwareAffected VersionHow to fix
Atlassian Confluence Data Center>=6.1.0<7.13.20
Atlassian Confluence Data Center>=7.14.0<7.19.8
Atlassian Confluence Data Center>=7.20.0<8.2.0
Atlassian Confluence Server>=6.1.0<7.13.20
Atlassian Confluence Server>=7.14.0<7.19.8
Atlassian Confluence Server>=7.20.0<8.2.0
Atlassian Confluence Data Center>=8.0.0<8.2.0
Atlassian Confluence Server>=8.0.0<8.2.0

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2023-22508?

    CVE-2023-22508 is a high severity RCE (Remote Code Execution) vulnerability in Confluence Data Center & Server.

  • How severe is CVE-2023-22508?

    CVE-2023-22508 has a severity score of 8.8, which is classified as high.

  • How does CVE-2023-22508 impact Confluence Data Center & Server?

    CVE-2023-22508 allows an authenticated attacker to execute arbitrary code, posing a high risk to the affected software.

  • Which versions of Confluence Data Center & Server are affected by CVE-2023-22508?

    CVE-2023-22508 affects versions 6.1.0 to 7.13.20 and versions 7.14.0 to 7.19.8 of Confluence Data Center & Server.

  • How can I mitigate the CVE-2023-22508 vulnerability?

    To mitigate the CVE-2023-22508 vulnerability, it is recommended to update Confluence Data Center & Server to versions 7.13.21, 7.19.9, or 8.2.1 or later.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203