863 22
Advisory Published

CVE-2023-22518: Atlassian Confluence Data Center and Server Improper Authorization Vulnerability

First published: Tue Oct 31 2023(Updated: )

All versions of Confluence Data Center and Server are affected by this unexploited vulnerability. This Improper Authorization vulnerability allows an unauthenticated attacker to reset Confluence and create a Confluence instance administrator account. Using this account, an attacker can then perform all administrative actions that are available to Confluence instance administrator leading to - but not limited to - full loss of confidentiality, integrity and availability.  Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.

Credit: security@atlassian.com

Affected SoftwareAffected VersionHow to fix
Atlassian Confluence Data Center>=1.0.0<7.19.16
Atlassian Confluence Data Center>=7.20.0<8.3.4
Atlassian Confluence Data Center>=8.4.0<8.4.4
Atlassian Confluence Data Center>=8.5.0<8.5.3
Atlassian Confluence Data Center=8.6.0
Atlassian Confluence Server>=1.0.0<7.19.16
Atlassian Confluence Server>=7.20.0<8.3.4
Atlassian Confluence Server>=8.4.0<8.4.4
Atlassian Confluence Server>=8.5.0<8.5.3
Atlassian Confluence Server=8.6.0


Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Peer vulnerabilities

(Found alongside the following vulnerabilities)

Frequently Asked Questions

  • What is the vulnerability ID?

    The vulnerability ID is CVE-2023-22518.

  • What is the title of the vulnerability?

    The title of the vulnerability is Atlassian Confluence Data Center and Server Improper Authorization Vulnerability.

  • Which software is affected by this vulnerability?

    Confluence Data Center and Server, specifically, Atlassian Confluence Data Center and Server, are affected by this vulnerability.

  • How severe is the vulnerability?

    The severity of the vulnerability is critical, with a severity value of 10.

  • How can I fix this vulnerability?

    To fix this vulnerability, update your Confluence Data Center and Server to a version that includes the security patch provided by Atlassian.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203