CVE-2023-22730: Shopware vulnerable to Improper Input Validation of Clearance sale in cart

Published Jan 17, 2023
·
Updated

Impact It is possible to put the same line item multiple one in the cart using API, the Cart Validators checked the line item's individuality and the user was able to skip the clearance sale in cart

Patches The problem has been fixed with 6.4.18.1

Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Or disable the newsletter registration completely.

References https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates

Other sources

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.

Shopware vulnerable to Improper Input Validation of Clearance sale in cart

— Packagist

Affected Software

5 affected componentsFixes available
Shopware Shopware<6.4.18.1
composer/shopware/core<=6.4.18.0
composer/shopware/platform<=6.4.18.0
composer/shopware/core<=6.4.18.0
6.4.18.1
composer/shopware/platform<=6.4.18.0
6.4.18.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/shopware/core to a version that resolves this vulnerability.

    Fixed in 6.4.18.1
  2. Upgrade

    Upgrade composer/shopware/platform to a version that resolves this vulnerability.

    Fixed in 6.4.18.1
  3. Upgrade

    Upgrade Shopware to a version that resolves this vulnerability.

    Fixed in 6.4.18.1
  4. Configuration

    Disable newsletter registration completely.

    Shopware newsletter registration newsletter registration = disabled

Event History

Jan 17, 2023
CVE Published
via MITRE·09:27 PM
Data Sourced
via MITRE·09:27 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·10:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·11:57 PM
Data Sourced
via GitHub·11:57 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·11:57 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2023-22730?

CVE-2023-22730 is a vulnerability in Shopware that allows users to bypass quantity limits in the shopping cart.

2

How does CVE-2023-22730 affect Shopware?

CVE-2023-22730 affects Shopware versions up to 6.4.18.1 and allows users to add the same line item multiple times in the cart using the AP.

3

What is the severity of CVE-2023-22730?

The severity of CVE-2023-22730 is high, with a CVSS score of 7.5.

4

How can I fix CVE-2023-22730?

To fix CVE-2023-22730, it is recommended to update Shopware to a version that includes the necessary security patches.

5

Where can I find more information about CVE-2023-22730?

More information about CVE-2023-22730 can be found in the official Shopware security update page and the related GitHub links.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203