CVE-2023-23454: Medium severity Linux Linux kernel vulnerability
An out-of-bounds (OOB) read problem was found in cbqclassify in net/sched/schcbq.c in the Linux kernel. This flaw allows a local attacker to cause a denial of service because of type confusion (non-negative numbers can sometimes indicate a TCACTSHOT condition rather than valid classification results).
Reference: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=caa4b35b4317d5147b3ab0fbdc9c075c7d2e9c12
Other sources
An out-of-bounds (OOB) read problem was found in cbqclassify in net/sched/schcbq.c in the Linux kernel. This issue may allow a local attacker to cause a denial of service due to type confusion. Non-negative numbers could indicate a TCACTSHOT condition rather than valid classification results.
cbqclassify in net/sched/schcbq.c in the Linux kernel through 6.1.4 allows attackers to cause a denial of service (slab-out-of-bounds read) because of type confusion (non-negative numbers can sometimes indicate a TCACTSHOT condition rather than valid classification results).
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.rt7.274.el8_8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-477.10.1.el8_8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.2 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Configuration
Disable unprivileged user namespaces by setting user.max_user_namespaces=0 in /etc/sysctl.d/userns.conf and apply it with sysctl -p /etc/sysctl.d/userns.conf.
Linux kernel user.max_user_namespaces = 0 - Configuration
Blacklist the affected cbq kernel module to prevent the affected code from being loaded.
Linux kernel module cbq module blacklist = blacklisted
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2023-23454?
CVE-2023-23454 is rated as high severity due to its potential for causing denial of service.
How do I fix CVE-2023-23454?
To mitigate CVE-2023-23454, you should update to the patched versions of the affected Linux kernel versions mentioned in the advisory.
What versions are affected by CVE-2023-23454?
CVE-2023-23454 affects various versions of the Linux kernel, specifically versions prior to 4.18.0-477.10.1 and below 6.2.
Who can exploit CVE-2023-23454?
CVE-2023-23454 can be exploited by a local attacker with the ability to execute code on the affected system.
What systems are impacted by CVE-2023-23454?
CVE-2023-23454 impacts systems running affected versions of the Linux kernel, including distributions like Red Hat and Debian.