CVE-2023-23922: Moodle Cross-site Scripting vulnerability

Published Jan 19, 2023
·
Updated

Blog search required additional sanitizing to prevent a reflected XSS risk.

Versions affected: 4.1 and 4.0 to 4.0.5 Versions fixed: 4.1.1, 4.0.6

Other sources

Moodle Cross-site Scripting vulnerability

— Packagist

The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in blog search. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.

— MITRE

Affected Software

8 affected componentsFixes available
Moodle Moodle>=4.0.0<4.0.6
Moodle Moodle=4.1.0
composer/moodle/moodle>=4.1.0-beta, <4.1.1
4.1.1
composer/moodle/moodle>=4.0.0-beta, <4.0.6
4.0.6
composer/moodle/moodle>=4.1.0-beta<4.1.1
4.1.1
composer/moodle/moodle>=4.0.0-beta<4.0.6
4.0.6
redhat/moodle<4.1.1
4.1.1
redhat/moodle<4.0.6
4.0.6

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.1
  2. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.1
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.6
  5. Upgrade

    Upgrade Moodle 4.1 to a version that resolves this vulnerability.

    Fixed in 4.1.1
  6. Upgrade

    Upgrade Moodle 4.0 to a version that resolves this vulnerability.

    Fixed in 4.0.6

Event History

Jan 19, 2023
Data Sourced
via Red Hat·10:14 PM
DescriptionSeverityAffected Software
Feb 17, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the vulnerability ID for this Moodle vulnerability?

The vulnerability ID for this Moodle vulnerability is CVE-2023-23922.

2

What is the severity of CVE-2023-23922?

The severity of CVE-2023-23922 is high with a CVSS score of 6.1.

3

How does the vulnerability CVE-2023-23922 occur in Moodle?

The vulnerability CVE-2023-23922 occurs in Moodle due to insufficient sanitization of user-supplied data in blog search.

4

How can a remote attacker exploit CVE-2023-23922?

A remote attacker can exploit CVE-2023-23922 by tricking the victim to follow a specially crafted link and execute arbitrary HTML and script code in the user's browser in the context of the vulnerable website.

5

Are there any patches or updates available for CVE-2023-23922?

Yes, there are patches available for CVE-2023-23922. The recommended version to fix this vulnerability is Moodle 4.1.1.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203