CVE-2023-24607: High severity Qt QT vulnerability
Qt before 6.4.3 allows a denial of service via a crafted string when the SQL ODBC driver plugin is used and the size of SQLTCHAR is 4. The affected versions are 5.x before 5.15.13, 6.x before 6.2.8, and 6.3.x before 6.4.3.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Qt 5.xto a version that resolves this vulnerability.Fixed in 5.15.13 - Upgrade
Upgrade
Qt 6.xto a version that resolves this vulnerability.Fixed in 6.2.8 - Upgrade
Upgrade
Qt 6.3.xto a version that resolves this vulnerability.Fixed in 6.4.3
Event History
Frequently Asked Questions
What is the vulnerability ID for this Qt vulnerability?
The vulnerability ID for this Qt vulnerability is CVE-2023-24607.
What is the severity of CVE-2023-24607?
The severity of CVE-2023-24607 is high with a CVSS score of 7.5.
How does CVE-2023-24607 result in a denial of service?
CVE-2023-24607 results in a denial of service by exploiting a crafted string when the SQL ODBC driver plugin is used.
Which versions of Qt are affected by CVE-2023-24607?
Versions 5.x before 5.15.13, 6.x before 6.2.8, and 6.3.x before 6.4.3 of Qt are affected by CVE-2023-24607.
Are there any fixes available for CVE-2023-24607?
Yes, the fix for CVE-2023-24607 is available in Qt version 6.4.3.