8.8
Advisory Published
Updated

CVE-2023-24927: Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability

First published: Tue Apr 11 2023(Updated: )

Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability

Credit: secure@microsoft.com

Affected SoftwareAffected VersionHow to fix
Microsoft Windows 10=20H2
Microsoft Windows 11=21H2
Microsoft Windows 11=21H2
Microsoft Windows 11=22H2
Microsoft Windows Server 2012
Microsoft Windows Server 2019
Microsoft Windows Server 2012
Microsoft Windows 11=22H2
Microsoft Windows Server 2019
Microsoft Windows Server 2022
Microsoft Windows Server 2022
Microsoft Windows 10
Microsoft Windows 10
Microsoft Windows 10=21H2
Microsoft Windows 10=21H2
Microsoft Windows 10=21H2
Microsoft Windows 10=1607
Microsoft Windows 10=1607
Microsoft Windows 10=22H2
Microsoft Windows 10=22H2
Microsoft Windows 10=22H2
Microsoft Windows 10=1809
Microsoft Windows 10=1809
Microsoft Windows 10=1809
Microsoft Windows 10=20H2
Microsoft Windows 10=20H2
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Microsoft Windows Server 2016
Microsoft Windows 10 1507<10.0.10240.19869
Microsoft Windows 10 1607<10.0.14393.5850
Microsoft Windows 10 1809<10.0.17763.4252
Microsoft Windows 10 20h2<10.0.19042.2846
Microsoft Windows 10 21h2<10.0.19044.2846
Microsoft Windows 10 22h2<10.0.19045.2846
Microsoft Windows 11 21h2<10.0.22000.1817
Microsoft Windows 11 22h2<10.0.22621.1555
Microsoft Windows Server 2012
Microsoft Windows Server 2012=r2
Microsoft Windows Server 2016
Microsoft Windows Server 2019
Microsoft Windows Server 2022

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2023-24927?

    CVE-2023-24927 refers to the Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability.

  • What software is affected by CVE-2023-24927?

    Windows 10 (versions 20H2, 21H2, and 22H2), Windows Server 2016, Windows Server 2019, and Windows Server 2022 are affected by CVE-2023-24927.

  • How severe is CVE-2023-24927?

    CVE-2023-24927 has a severity score of 8.8, considered high.

  • How can I fix CVE-2023-24927?

    You can fix CVE-2023-24927 by applying the patch available from Microsoft or following the provided remediation URL for your specific operating system version.

  • Where can I find more information about CVE-2023-24927?

    You can find more information about CVE-2023-24927 on the Microsoft Security Response Center website.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203