CVE-2023-25727: Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin

Published Feb 13, 2023
·
Updated

Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin

Other sources

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger Cross-site Scripting (XSS) by uploading a crafted .sql file through the drag-and-drop interface. By disabling the configuration directive $cfg['enabledragdropimport'], users will be unable to use the drag and drop upload which would protect against the vulnerability.

— GitHub

In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.

Affected Software

6 affected componentsFixes available
phpMyAdmin phpMyAdmin<4.9.11
phpMyAdmin phpMyAdmin>=5.0.0<5.2.1
composer/phpmyadmin/phpmyadmin>=5.0<5.2.1
5.2.1
composer/phpmyadmin/phpmyadmin>=4.3.0<4.9.11
4.9.11
composer/phpmyadmin/phpmyadmin>=5.0, <5.2.1
5.2.1
composer/phpmyadmin/phpmyadmin>=4.3.0, <4.9.11
4.9.11

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 5.2.1
  2. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.9.11
  3. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.9.11
  4. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 5.2.1
  5. Configuration

    Disable the $cfg['enable_drag_drop_import'] configuration directive to prevent use of drag-and-drop uploads.

    phpMyAdmin $cfg['enable_drag_drop_import'] = disabled

Event History

Feb 13, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·06:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·06:30 AM
Data Sourced
via GitHub·06:30 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·06:30 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2023-25727?

The severity of CVE-2023-25727 is medium with a CVSS score of 5.4.

2

How can an attacker exploit CVE-2023-25727?

An attacker can exploit CVE-2023-25727 by uploading a crafted .sql file through the drag-and-drop interface in phpMyAdmin.

3

Which versions of phpMyAdmin are affected by CVE-2023-25727?

phpMyAdmin versions before 4.9.11 and 5.x before 5.2.1 are affected by CVE-2023-25727.

4

How can I fix CVE-2023-25727?

To fix CVE-2023-25727, update phpMyAdmin to version 4.9.11 or 5.2.1 or later.

5

Where can I find more information about CVE-2023-25727?

More information about CVE-2023-25727 can be found on the official phpMyAdmin website: https://www.phpmyadmin.net/security/PMASA-2023-1/

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203