CVE-2023-26159: Input Validation

Published Jan 2, 2024
·
Updated

ollow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site, potentially leading to information disclosure, phishing attacks, or other security breaches.

https://github.com/follow-redirects/follow-redirects/issues/235 https://github.com/follow-redirects/follow-redirects/pull/236 https://security.snyk.io/vuln/SNYK-JS-FOLLOWREDIRECTS-6141137

Other sources

Versions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site potentially leading to information disclosure phishing attacks or other security breaches.

— Microsoft

Versions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site, potentially leading to information disclosure, phishing attacks, or other security breaches.

— GitHub

Affected Software

6 affected componentsFixes available
npm/follow-redirects<1.15.4
1.15.4
follow-redirects Follow Redirects Node.js<1.15.4
Microsoft cbl2 reaper 3.1.1-8
Microsoft azl3 python-tensorboard 2.11.0-3
Microsoft azl3 python-tensorboard 2.16.2-1
IBM API Connect V12 OnPrem<=v12.1.0.0 - v12.1.1.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/follow-redirects to a version that resolves this vulnerability.

    Fixed in 1.15.4
  2. Upgrade

    Upgrade follow-redirects to a version that resolves this vulnerability.

    Fixed in 1.15.4

Event History

Jan 2, 2024
CVE Published
via MITRE·05:00 AM
Data Sourced
via MITRE·05:00 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·06:30 AM
Data Sourced
via Red Hat·07:00 AM
DescriptionSeverityAffected Software
Jan 8, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software
Oct 8, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2023-26159?

CVE-2023-26159 has been classified as a moderate severity vulnerability due to its potential for phishing attacks.

2

How do I fix CVE-2023-26159?

To fix CVE-2023-26159, upgrade the follow-redirects package to version 1.15.4 or later.

3

What does CVE-2023-26159 affect?

CVE-2023-26159 affects the follow-redirects package versions prior to 1.15.4 and certain versions of IBM Cognos Controller.

4

Can CVE-2023-26159 be exploited remotely?

Yes, CVE-2023-26159 can be exploited remotely by an attacker using a specially crafted URL to redirect users.

5

What type of vulnerability is CVE-2023-26159?

CVE-2023-26159 is classified as an open redirect vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203