CVE-2023-27891: High severity pretix vulnerability
Published Mar 6, 2023
·Updated
rami.io pretix before 4.17.1 allows OAuth application authorization from a logged-out session. The fixed versions are 4.15.1, 4.16.1, and 4.17.1.
Affected Software
6 affected componentsFixes available
pip/pretix<4.15.1
4.15.1
pip/pretix>=4.16.0<4.16.1
4.16.1
pip/pretix>=4.17.0<4.17.1
4.17.1
rami pretix>=1.16.0<4.15.1
rami pretix=4.16.0
rami pretix=4.17.0
Event History
Mar 6, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Mar 7, 2023
Advisory Published
via GitHub·12:30 AM
Frequently Asked Questions
1
What is CVE-2023-27891?
CVE-2023-27891 is a vulnerability in rami.io pretix before version 4.17.1 that allows OAuth application authorization from a logged-out session.
2
What is the severity of CVE-2023-27891?
The severity of CVE-2023-27891 is high with a CVSS score of 7.5.
3
How does CVE-2023-27891 impact rami.io pretix?
CVE-2023-27891 allows OAuth application authorization from a logged-out session, which can lead to unauthorized access to user data in rami.io pretix.
4
Which versions of rami.io pretix are affected by CVE-2023-27891?
Versions 1.16.0 to 4.15.1, version 4.16.0, and version 4.17.0 of rami.io pretix are affected by CVE-2023-27891.
5
How can CVE-2023-27891 be fixed?
CVE-2023-27891 can be fixed by updating rami.io pretix to versions 4.15.1, 4.16.1, or 4.17.1, which contain the necessary fixes.