CVE-2023-28330: Moodle arbitrary file read vulnerability

Published Mar 17, 2023
·
Updated

Insufficient sanitizing in backup resulted in an arbitrary file read risk. The capability to access this feature is only available to teachers, managers and admins by default.

Other sources

Moodle arbitrary file read vulnerability

— Packagist

Affected Software

20 affected componentsFixes available
redhat/moodle<4.1.2
4.1.2
redhat/moodle<4.0.7
4.0.7
redhat/moodle<3.11.13
3.11.13
redhat/moodle<3.9.20
3.9.20
composer/moodle/moodle<3.9.20
3.9.20
composer/moodle/moodle>=3.11.0<3.11.13
3.11.13
composer/moodle/moodle>=4.0.0<4.0.7
4.0.7
composer/moodle/moodle>=4.1.0<4.1.2
4.1.2
Moodle Moodle>3.9.0<3.9.20
Moodle Moodle>3.11.0<3.11.13
Moodle Moodle>4.0.0<4.0.7
Moodle Moodle=3.9.0
Moodle Moodle=3.11.0
Moodle Moodle=4.0.0
Moodle Moodle=4.1.0
Moodle Moodle=4.1.1
composer/moodle/moodle<3.9.20
3.9.20
composer/moodle/moodle>=3.11.0, <3.11.13
3.11.13
composer/moodle/moodle>=4.0.0, <4.0.7
4.0.7
composer/moodle/moodle>=4.1.0, <4.1.2
4.1.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.2
  2. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.7
  3. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.13
  4. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 3.9.20
  5. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.9.20
  6. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.13
  7. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.7
  8. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.2

Event History

Mar 23, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·09:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2023-28330?

CVE-2023-28330 is a vulnerability in Moodle, which allows teachers, managers, and admins to read arbitrary files through a backup feature.

2

Who is affected by CVE-2023-28330?

Moodle versions 3.9.0 to 3.9.20, 3.11.0 to 3.11.13, 4.0.0 to 4.0.7, 4.1.0, and 4.1.1 are affected by CVE-2023-28330.

3

What is the severity of CVE-2023-28330?

CVE-2023-28330 has a severity score of 6.5, which is considered a medium severity vulnerability.

4

How can I fix CVE-2023-28330?

To fix CVE-2023-28330, users should update their Moodle installation to a version that is not affected by the vulnerability.

5

Where can I find more information about CVE-2023-28330?

More information about CVE-2023-28330 can be found in the references provided: [Reference 1](https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF/) and [Reference 2](https://moodle.org/mod/forum/discuss.php?d=445062).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203