CVE-2023-28332: Moodle vulnerable to Cross-site Scripting when algebra filter enabled but not functional

Published Mar 17, 2023
·
Updated

If the algebra filter was enabled but not functional (eg the necessary binaries were missing from the server), it presented an XSS risk.

Other sources

Moodle vulnerable to Cross-site Scripting when algebra filter enabled but not functional

— Packagist

Affected Software

20 affected componentsFixes available
redhat/moodle<4.1.2
4.1.2
redhat/moodle<4.0.7
4.0.7
redhat/moodle<3.11.13
3.11.13
redhat/moodle<3.9.20
3.9.20
composer/moodle/moodle<3.9.20
3.9.20
composer/moodle/moodle>=3.11.0<3.11.13
3.11.13
composer/moodle/moodle>=4.0.0<4.0.7
4.0.7
composer/moodle/moodle>=4.1.0<4.1.2
4.1.2
Moodle Moodle>3.9.0<3.9.20
Moodle Moodle>3.11.0<3.11.13
Moodle Moodle>4.0.0<4.0.7
Moodle Moodle=3.9.0
Moodle Moodle=3.11.0
Moodle Moodle=4.0.0
Moodle Moodle=4.1.0
Moodle Moodle=4.1.1
composer/moodle/moodle<3.9.20
3.9.20
composer/moodle/moodle>=3.11.0, <3.11.13
3.11.13
composer/moodle/moodle>=4.0.0, <4.0.7
4.0.7
composer/moodle/moodle>=4.1.0, <4.1.2
4.1.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.2
  2. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.7
  3. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.13
  4. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 3.9.20
  5. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.9.20
  6. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.13
  7. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.0.7
  8. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.2

Event History

Mar 23, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via NVD·09:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·09:30 PM
Data Sourced
via GitHub·09:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2023-28332?

CVE-2023-28332 is a vulnerability in Moodle that allowed for XSS attacks when the algebra filter was enabled but not functional.

2

How does CVE-2023-28332 impact Moodle?

CVE-2023-28332 presented an XSS risk in Moodle if the algebra filter was enabled but not functional.

3

What is the severity of CVE-2023-28332?

CVE-2023-28332 has a severity value of 6.1, which is classified as medium.

4

Which versions of Moodle are affected by CVE-2023-28332?

Moodle versions 3.9.0 to 3.9.20, 3.11.0 to 3.11.13, 4.0.0 to 4.0.7, 4.1.0, and 4.1.1 are affected by CVE-2023-28332.

5

How can I mitigate the risk of CVE-2023-28332?

To mitigate the risk of CVE-2023-28332, ensure that the necessary binaries for the algebra filter are present on the server.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203