CVE-2023-29181: High severity Fortinet FortiProxy vulnerability
A use of externally-controlled format string vulnerability in Fortinet FortiOS 7.2.0 through 7.2.4, FortiOS 7.0.0 through 7.0.11, FortiOS 6.4.0 through 6.4.12, FortiOS 6.2.0 through 6.2.14, FortiOS 6.0.0 through 6.0.16, FortiOS 5.6 all versions, FortiOS 5.4 all versions, FortiOS 5.2 all versions, FortiOS 5.0 all versions, FortiOS 4.3 all versions, FortiOS 4.2 all versions, FortiOS 4.1 all versions, FortiOS 4.0 all versions, FortiPAM 1.0 all versions, FortiProxy 7.2.0 through 7.2.4, FortiProxy 7.0.0 through 7.0.10, FortiProxy 2.0.0 through 2.0.12, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions allows attacker to execute unauthorized code or commands via specially crafted command.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 6.0.17 - Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 6.2.15 - Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 6.4.13 - Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 7.0.12 - Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 7.2.5 - Upgrade
Upgrade
Fortinet FortiOSto a version that resolves this vulnerability.Fixed in 7.4.1 - Upgrade
Upgrade
Fortinet FortiPAMto a version that resolves this vulnerability.Fixed in 1.1.0 - Upgrade
Upgrade
Fortinet FortiProxyto a version that resolves this vulnerability.Fixed in 2.0.13 - Upgrade
Upgrade
Fortinet FortiProxyto a version that resolves this vulnerability.Fixed in 7.0.11 - Upgrade
Upgrade
Fortinet FortiProxyto a version that resolves this vulnerability.Fixed in 7.2.5
Event History
Frequently Asked Questions
What is the severity of CVE-2023-29181?
CVE-2023-29181 has been classified as a critical vulnerability due to its potential for exploitation leading to arbitrary code execution.
How do I fix CVE-2023-29181?
To address CVE-2023-29181, upgrade your FortiOS or FortiProxy software to the latest version available that is not affected by this vulnerability.
What systems are affected by CVE-2023-29181?
CVE-2023-29181 affects multiple versions of FortiOS and FortiProxy, specifically versions within 7.2.0 to 7.2.4, 7.0.0 to 7.0.11, and earlier versions.
Is CVE-2023-29181 remotely exploitable?
Yes, CVE-2023-29181 can be remotely exploited by attackers, potentially allowing them to execute arbitrary code on the affected systems.
What are the potential impacts of CVE-2023-29181?
Exploitation of CVE-2023-29181 may lead to data breaches, unauthorized access, and compromise of sensitive information on affected devices.