CVE-2023-34194: High severity Tinyxml Project Tinyxml vulnerability
StringEqual in TiXmlDeclaration::Parse in tinyxmlparser.cpp in TinyXML through 2.6.2 has a reachable assertion (and application exit) via a crafted XML document with a '\0' located after whitespace.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-4+deb10u2Fixed in 2.6.2-4+deb11u2Fixed in 2.6.2-6+deb12u1Fixed in 2.6.2-6.1 - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-4ubuntu0.18.04.1~ - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-4+ - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-6ubuntu0.22.04.1 - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-6ubuntu0.23.10.1 - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-6.1 - Upgrade
Upgrade
ubuntu/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-3ubuntu0.1~ - Upgrade
Upgrade
alpine/tinyxmlto a version that resolves this vulnerability.Fixed in 2.6.2-r4
Event History
Frequently Asked Questions
What is the severity of CVE-2023-34194?
CVE-2023-34194 is considered a security vulnerability that leads to a reachable assertion failure and application exit.
How do I fix CVE-2023-34194?
To fix CVE-2023-34194, upgrade TinyXML to a version above 2.6.2, such as 2.6.2-5 or later.
Which versions of TinyXML are affected by CVE-2023-34194?
CVE-2023-34194 affects all TinyXML versions up to and including 2.6.2.
What software is impacted by CVE-2023-34194?
CVE-2023-34194 impacts TinyXML versions through 2.6.2 across various Debian and Ubuntu packages.
Is there a specific patch for CVE-2023-34194?
There is no specific patch; users need to upgrade to the fixed version of TinyXML to mitigate CVE-2023-34194.