CVE-2023-37328: GStreamer PGS File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability
GStreamer PGS File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.
The specific flaw exists within the parsing of PGS subtitle files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-20994.
Other sources
Heap-based buffer overflow in the subparse subtitle parser when handling certain SRT subtitle files in GStreamer versions before 1.22.4 / 1.20.7. It is possible for a malicious third party to trigger a crash in the application, and possibly also effect code execution through heap manipulation.
https://gstreamer.freedesktop.org/security/sa-2023-0002.html
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/gst-plugins-base1.0to a version that resolves this vulnerability.Fixed in 1.22.4-1 - Upgrade
Upgrade
ubuntu/gst-plugins-base1.0to a version that resolves this vulnerability.Fixed in 1.16.3-0ubuntu1.2 - Upgrade
Upgrade
ubuntu/gst-plugins-base1.0to a version that resolves this vulnerability.Fixed in 1.20.1-1ubuntu0.1 - Upgrade
Upgrade
ubuntu/gst-plugins-base1.0to a version that resolves this vulnerability.Fixed in 1.22.1-1ubuntu1.1 - Upgrade
Upgrade
debian/gst-plugins-base1.0to a version that resolves this vulnerability.Fixed in 1.14.4-2+deb10u2Fixed in 1.18.4-2+deb11u1Fixed in 1.22.0-3+deb12u1Fixed in 1.22.9-1 - Upgrade
Upgrade
redhat/gst-plugins-baseto a version that resolves this vulnerability.Fixed in 1.22.4 - Upgrade
Upgrade
redhat/gst-plugins-baseto a version that resolves this vulnerability.Fixed in 1.20.7 - Upgrade
Upgrade
GStreamerto a version that resolves this vulnerability.Fixed in 1.22.4 - Upgrade
Upgrade
GStreamerto a version that resolves this vulnerability.Fixed in 1.20.7
Event History
Frequently Asked Questions
What is the severity of CVE-2023-37328?
CVE-2023-37328 is classified as a critical security vulnerability that allows remote code execution.
How do I fix CVE-2023-37328?
To fix CVE-2023-37328, upgrade to the latest versions of GStreamer, specifically 1.22.4-1 or newer.
What systems are affected by CVE-2023-37328?
CVE-2023-37328 affects multiple installations of GStreamer across various distributions including Ubuntu and Debian.
Can CVE-2023-37328 be exploited remotely?
Yes, CVE-2023-37328 can be exploited remotely, allowing attackers to execute arbitrary code on vulnerable systems.
What kind of vulnerability is CVE-2023-37328?
CVE-2023-37328 is a heap-based buffer overflow vulnerability that can lead to remote code execution.