CVE-2023-38219: Magento Open Source allows Cross-Site Scripting (XSS)
Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Payload is stored in an admin area, resulting in high confidentiality and integrity impact.
Other sources
Magento Open Source allows Cross-Site Scripting (XSS)
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.4-p6 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.5-p5 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.6-p3 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.7-beta2
Event History
Frequently Asked Questions
What is the severity of CVE-2023-38219?
CVE-2023-38219 has been classified as a moderate severity vulnerability affecting Adobe Commerce versions 2.4.7-beta1 and earlier.
How do I fix CVE-2023-38219?
To remediate CVE-2023-38219, upgrade Adobe Commerce to a version that is not affected, specifically version 2.4.7 or later.
Who can exploit CVE-2023-38219?
CVE-2023-38219 can be exploited by low-privileged attackers to inject malicious scripts into vulnerable form fields.
What type of vulnerability is CVE-2023-38219?
CVE-2023-38219 is identified as a stored Cross-Site Scripting (XSS) vulnerability.
Which Adobe Commerce versions are affected by CVE-2023-38219?
Adobe Commerce versions 2.3.7 and 2.4.0 through 2.4.6-p2 are affected by CVE-2023-38219.