3.7
CWE
119
Advisory Published
CVE Published
CVE Published
Advisory Published
Advisory Published
Updated

CVE-2023-38546: curl and libcurl CVE-2023-38545 and CVE-2023-38546 vulnerabilities

First published: Tue Oct 03 2023(Updated: )

cURL libcurl could allow a remote attacker to bypass security restrictions, caused by a flaw in the curl_easy_duphandle function if a transfer has cookies enabled when the handle is duplicated. By sending a specially crafted request, an attacker could exploit this vulnerability to insert cookies at will into a running program.

Credit: support@hackerone.com CVE-2023-38545 CVE-2023-38039 CVE-2023-38546 CVE-2023-42915 support@hackerone.com support@hackerone.com CVE-2023-38545 CVE-2023-38039 CVE-2023-38546 CVE-2023-38545 CVE-2023-38039 CVE-2023-38546 CVE-2023-38545 CVE-2023-38039 CVE-2023-38546

Affected SoftwareAffected VersionHow to fix
Haxx Libcurl>=7.9.1<8.4.0
Apple iOS<16.7.5
16.7.5
Apple iPadOS<16.7.5
16.7.5
Apple macOS Sonoma<14.2
14.2
Apple macOS Ventura<13.6.4
13.6.4
Apple macOS Monterey<12.7.3
12.7.3
redhat/curl<8.4.0
8.4.0
ubuntu/curl<7.58.0-2ubuntu3.24+
7.58.0-2ubuntu3.24+
ubuntu/curl<7.68.0-1ubuntu2.20
7.68.0-1ubuntu2.20
ubuntu/curl<7.81.0-1ubuntu1.14
7.81.0-1ubuntu1.14
ubuntu/curl<7.88.1-8ubuntu2.3
7.88.1-8ubuntu2.3
ubuntu/curl<8.2.1-1ubuntu3.1
8.2.1-1ubuntu3.1
ubuntu/curl<8.2.1-1ubuntu3.1
8.2.1-1ubuntu3.1
ubuntu/curl<7.35.0-1ubuntu2.20+
7.35.0-1ubuntu2.20+
ubuntu/curl<7.47.0-1ubuntu2.19+
7.47.0-1ubuntu2.19+
IBM QRadar SIEM<=7.5 - 7.5.0 UP8 IF01
debian/curl
7.74.0-1.3+deb11u12
7.74.0-1.3+deb11u11
7.88.1-10+deb12u6
7.88.1-10+deb12u5
8.8.0-1
8.8.0-4

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Reference Links

Parent vulnerabilities

(Appears in the following advisories)

Frequently Asked Questions

  • What is CVE-2023-38546?

    CVE-2023-38546 is a vulnerability in curl that allows cookie injection with none file.

  • How does CVE-2023-38546 affect Ubuntu?

    CVE-2023-38546 affects Ubuntu versions 7.68.0-1ubuntu2.20, 7.81.0-1ubuntu1.14, and 7.88.1-8ubuntu2.3.

  • How does CVE-2023-38546 affect Debian?

    CVE-2023-38546 affects Debian versions 7.64.0-4+deb10u7, 7.74.0-1.3+deb11u10, 7.88.1-10+deb12u4, and 8.3.0-3.

  • Where can I find more information about CVE-2023-38546?

    You can find more information about CVE-2023-38546 on the MITRE CVE website, the curl documentation, and the Ubuntu security notices page.

  • How can I fix CVE-2023-38546?

    To fix CVE-2023-38546, update curl to the recommended versions provided by the respective Linux distributions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203