CVE-2023-3966: Openvswsitch: ovs-vswitch fails to recover after malformed geneve metadata packet
A flaw was found in Open vSwitch where multiple versions are vulnerable to crafted Geneve packets, which may result in a denial of service and invalid memory accesses. Triggering this issue requires that hardware offloading via the netlink path is enabled.
Other sources
ovs-vswitch fails to recover after malformed geneve metadata packet
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/openvswitchto a version that resolves this vulnerability.Fixed in 2.10.7+ds1-0+deb10u1Fixed in 2.10.7+ds1-0+deb10u5Fixed in 2.15.0+ds1-2+deb11u5Fixed in 3.1.0-2+deb12u1Fixed in 3.3.0-1 - Upgrade
Upgrade
ubuntu/openvswitchto a version that resolves this vulnerability.Fixed in 2.13.8-0ubuntu1.4 - Upgrade
Upgrade
ubuntu/openvswitchto a version that resolves this vulnerability.Fixed in 2.17.9-0ubuntu0.22.04.1 - Upgrade
Upgrade
ubuntu/openvswitchto a version that resolves this vulnerability.Fixed in 3.2.2-0ubuntu0.23.10.1 - Upgrade
Upgrade
ubuntu/openvswitchto a version that resolves this vulnerability.Fixed in 2.17.9Fixed in 3.0.6Fixed in 3.1.4Fixed in 3.2.2 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 3.1.0 - Upgrade
Upgrade
alpine/openvswitchto a version that resolves this vulnerability.Fixed in 2.17.9-r0 - Configuration
Disable flow hardware offload by setting other_config:hw-offload=false.
Open vSwitch other_config:hw-offload = false
Event History
Frequently Asked Questions
What is the severity of CVE-2023-3966?
CVE-2023-3966 is categorized as a denial-of-service vulnerability.
How do I fix CVE-2023-3966?
To fix CVE-2023-3966, upgrade to the patched versions of Open vSwitch specified in the vulnerability advisory.
What versions of Open vSwitch are affected by CVE-2023-3966?
CVE-2023-3966 affects multiple versions including those before 2.17.9, 3.0.6, 3.1.4, and 3.2.2.
Is there a workaround for CVE-2023-3966?
Currently, the best approach to mitigate CVE-2023-3966 is to disable hardware offloading via the netlink path.
Which operating systems are impacted by CVE-2023-3966?
CVE-2023-3966 impacts various distributions including Ubuntu, Red Hat, and Debian running vulnerable versions of Open vSwitch.