7.5
CWE
228
Advisory Published
Updated

CVE-2023-39915

First published: Wed Sep 13 2023(Updated: )

NLnet Labs’ Routinator up to and including version 0.12.1 may crash when trying to parse certain malformed RPKI objects. This is due to insufficient input checking in the bcder library covered by CVE-2023-39914.

Credit: sep@nlnetlabs.nl sep@nlnetlabs.nl

Affected SoftwareAffected VersionHow to fix
Nlnetlabs Routinator<0.12.2

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is the vulnerability ID for NLnet Labs’ Routinator?

    The vulnerability ID for NLnet Labs’ Routinator is CVE-2023-39915.

  • What is the severity of CVE-2023-39915?

    The severity of CVE-2023-39915 is high with a severity value of 7.5.

  • What software is affected by CVE-2023-39915?

    NLnet Labs’ Routinator up to and including version 0.12.1 is affected by CVE-2023-39915.

  • What is the cause of CVE-2023-39915?

    CVE-2023-39915 is caused by insufficient input checking in the bcder library.

  • Where can I find more information about CVE-2023-39915?

    You can find more information about CVE-2023-39915 at the following link: [link](https://nlnetlabs.nl/downloads/routinator/CVE-2023-39915.txt).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203