CVE-2023-39976: Buffer Overflow
logblackbox.c in libqb before 2.0.8 allows a buffer overflow via long log messages because the header size is not considered.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/libqbto a version that resolves this vulnerability.Fixed in 2.0.4-1ubuntu0.2 - Upgrade
Upgrade
ubuntu/libqbto a version that resolves this vulnerability.Fixed in 2.0.6-2ubuntu0.1 - Upgrade
Upgrade
debian/libqbto a version that resolves this vulnerability.Fixed in 1.0.5-1Fixed in 2.0.8-1 - Upgrade
Upgrade
redhat/libqbto a version that resolves this vulnerability.Fixed in 2.0.8
Event History
Frequently Asked Questions
What is CVE-2023-39976?
CVE-2023-39976 is a vulnerability in libqb before 2.0.8 that allows a buffer overflow via long log messages.
What is the severity of CVE-2023-39976?
CVE-2023-39976 has a severity score of 9.8 (Critical).
How does CVE-2023-39976 affect Clusterlabs Libqb?
CVE-2023-39976 affects Clusterlabs Libqb versions up to and excluding 2.0.8.
How does CVE-2023-39976 affect Ubuntu libqb?
CVE-2023-39976 affects Ubuntu libqb versions 2.0.4-1ubuntu0.2 and 2.0.6-2ubuntu0.1.
How can I fix CVE-2023-39976?
To fix CVE-2023-39976, update libqb to version 2.0.8 or later.