CWE
20 79
Advisory Published
Advisory Published
Updated

CVE-2023-40314: Cross-site scripting in bootstrap.jsp

First published: Thu Nov 16 2023(Updated: )

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.

Credit: security@opennms.com security@opennms.com

Affected SoftwareAffected VersionHow to fix
OpenNMS Horizon<32.0.5
OpenNMS Meridian<2023.1.9
maven/org.opennms:opennms-webapp<32.0.5
32.0.5

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2023-40314?

    CVE-2023-40314 is a vulnerability that allows cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon.

  • How does CVE-2023-40314 affect OpenNMS Meridian and Horizon?

    CVE-2023-40314 allows an attacker access to confidential session information in OpenNMS Meridian and Horizon.

  • What is the severity of CVE-2023-40314?

    CVE-2023-40314 has a severity rating of 6.1 (medium).

  • How can I fix CVE-2023-40314?

    To fix CVE-2023-40314, you need to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer.

  • Where can I find more information about CVE-2023-40314?

    You can find more information about CVE-2023-40314 at the following link: [CVE-2023-40314](https://github.com/OpenNMS/opennms/pull/6791).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2023 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203