620 640
Advisory Published


First published: Sat Nov 18 2023(Updated: )

The AppPresser plugin for WordPress is vulnerable to unauthorized password resets in versions up to, and including 4.2.5. This is due to the plugin generating too weak a reset code, and the code used to reset the password has no attempt or time limit.


Affected SoftwareAffected VersionHow to fix
Apppresser Apppresser<4.3.0

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2023-4214?

    CVE-2023-4214 is a vulnerability in the AppPresser plugin for WordPress that allows unauthorized password resets.

  • How severe is CVE-2023-4214?

    CVE-2023-4214 is classified as critical with a severity score of 9.8.

  • Which version of the AppPresser plugin for WordPress is affected by CVE-2023-4214?

    Versions up to and including 4.2.5 of the AppPresser plugin for WordPress are affected by CVE-2023-4214.

  • How does CVE-2023-4214 work?

    CVE-2023-4214 occurs due to the AppPresser plugin generating a weak reset code, allowing unauthorized password resets with no time limit.

  • Are there any fixes available for CVE-2023-4214?

    Yes, it is recommended to update the AppPresser plugin for WordPress to version 4.3.0 or higher to fix CVE-2023-4214.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203