CVE-2023-4387: Kernel: vmxnet3: use-after-free in vmxnet3_rq_alloc_rx_buf()

Published Jul 3, 2023
·
Updated

A use-after-free flaw was found in vmxnet3rqallocrxbuf in drivers/net/vmxnet3/vmxnet3drv.c in VMware's vmxnet3 ethernet NIC driver in the Linux Kernel. This flaw could allow a local attacker to crash the system due to a double free while cleanup at vmxnet3rqcleanupall. This vulnerability could even lead to a kernel information leak problem.

In vmxnet3rqallocrxbuf(), when dmamapsingle() fails, rbi->skb is freed immediately. Similarly, in another branch, when dmamappage() fails, rbi->page is also freed. In the two cases, vmxnet3rqallocrxbuf() returns an error to its callers vmxnet3rqinit() -> vmxnet3rqinitall() -> vmxnet3activatedev(). Then vmxnet3activatedev() calls vmxnet3rqcleanupall() in error handling code, and rbi->skb or rbi->page are freed again in vmxnet3rqcleanupall(), causing use-after-free bugs.

References: https://github.com/torvalds/linux/commit/9e7fef9521e73ca8afd7da9e58c14654b02dfad8

Other sources

A use-after-free flaw was found in vmxnet3rqallocrxbuf in drivers/net/vmxnet3/vmxnet3drv.c in VMware's vmxnet3 ethernet NIC driver in the Linux Kernel. This issue could allow a local attacker to crash the system due to a double-free while cleaning up vmxnet3rqcleanupall, which could also lead to a kernel information leak problem.

— Launchpad

Affected Software

15 affected componentsFixes available
Linux Linux kernel>=3.16.60<3.17
Linux Linux kernel>=4.4<4.9.316
Linux Linux kernel>=4.10<4.14.281
Linux Linux kernel>=4.15<4.19.245
Linux Linux kernel>=4.20<5.4.196
Linux Linux kernel>=5.5<5.10.118
Linux Linux kernel>=5.11<5.15.42
Linux Linux kernel>=5.16<5.17.10
redhat Enterprise Linux=6.0
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux=9.0
Linux Linux kernel<5.18
debian/linux
5.10.223-15.10.234-16.1.129-16.1.135-16.12.22-16.12.25-1
redhat/kernel<5.18
5.18

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.22-1Fixed in 6.12.25-1
  2. Upgrade

    Upgrade redhat/Kernel to a version that resolves this vulnerability.

    Fixed in 5.18

Event History

Jul 3, 2023
Data Sourced
via Red Hat·07:04 AM
DescriptionSeverityAffected Software
Aug 16, 2023
CVE Published
via MITRE·06:49 PM
Data Sourced
via MITRE·06:49 PM
DescriptionSeverityWeakness

Frequently Asked Questions

1

What is the severity of CVE-2023-4387?

CVE-2023-4387 is classified as a high-severity vulnerability due to its potential to cause system crashes.

2

How do I fix CVE-2023-4387?

To fix CVE-2023-4387, you should upgrade to the latest kernel versions or specific patched versions mentioned in security advisories.

3

Which systems are affected by CVE-2023-4387?

CVE-2023-4387 affects various versions of the Linux Kernel, specifically between versions 3.16 and 5.18, including certain Red Hat Enterprise Linux versions.

4

What type of vulnerability is CVE-2023-4387?

CVE-2023-4387 is a use-after-free vulnerability that can lead to a double free condition during system operation.

5

Who can exploit CVE-2023-4387?

CVE-2023-4387 can potentially be exploited by local attackers with access to the affected system.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203