CVE-2023-44271: High severity Python Pillow vulnerability
An issue was discovered in Pillow before 10.0.0. It is a Denial of Service that uncontrollably allocates memory to process a given task, potentially causing a service to crash by having it run out of memory. This occurs for truetype in ImageFont when textlength in an ImageDraw instance operates on a long text argument.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/pillowto a version that resolves this vulnerability.Fixed in 7.0.0-4ubuntu0.8 - Upgrade
Upgrade
ubuntu/pillowto a version that resolves this vulnerability.Fixed in 9.0.1-1ubuntu0.2 - Upgrade
Upgrade
ubuntu/pillowto a version that resolves this vulnerability.Fixed in 10.0.0-1 - Upgrade
Upgrade
pip/pillowto a version that resolves this vulnerability.Fixed in 10.0.0 - Upgrade
Upgrade
redhat/Pillowto a version that resolves this vulnerability.Fixed in 10.0.0 - Upgrade
Upgrade
debian/pillowto a version that resolves this vulnerability.Fixed in 9.4.0-1.1+deb12u1Fixed in 11.1.0-5+deb13u4Fixed in 11.1.0-5+deb13u3Fixed in 12.3.0-1Fixed in 13.0.0-1