CVE-2023-44446: GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability

Published Nov 15, 2023
·
Updated

[MXF demuxer use-after-free]

Other sources

GStreamer MXF File Parsing Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the parsing of MXF video files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22299.

— MITRE

Use-after-free (read) in the MXF demuxer when handling certain files before GStreamer 1.22.7. It is possible for a malicious third party to trigger a crash in the application.

References: https://gstreamer.freedesktop.org/security/sa-2023-0010.html https://www.zerodayinitiative.com/advisories/ZDI-CAN-22299

Upstream MR & commit: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/mergerequests/5635 https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/7dfaa57b6f9b55f17ffe824bd8988bb71ae11353

— Red Hat

Affected Software

15 affected componentsFixes available
redhat/gstreamer-plugins-bad-free<1.22.7
1.22.7
ubuntu/gst-plugins-bad1.0<1.16.3-0ubuntu1.1
1.16.3-0ubuntu1.1
ubuntu/gst-plugins-bad1.0<1.20.3-0ubuntu1.1
1.20.3-0ubuntu1.1
ubuntu/gst-plugins-bad1.0<1.22.1-1ubuntu1.1
1.22.1-1ubuntu1.1
ubuntu/gst-plugins-bad1.0<1.22.4-1ubuntu1.1
1.22.4-1ubuntu1.1
debian/gst-plugins-bad1.0<=1.14.4-1+deb10u2
1.14.4-1+deb10u51.18.4-3+deb11u41.22.0-4+deb12u51.22.10-11.24.2-3
GStreamer GStreamer
GStreamer GStreamer<1.22.7
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0
alpine/gst-plugins-bad<1.22.7-r0
1.22.7-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/gstreamer-plugins-bad-free to a version that resolves this vulnerability.

    Fixed in 1.22.7
  2. Upgrade

    Upgrade ubuntu/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.16.3-0ubuntu1.1
  3. Upgrade

    Upgrade ubuntu/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.20.3-0ubuntu1.1
  4. Upgrade

    Upgrade ubuntu/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.22.1-1ubuntu1.1
  5. Upgrade

    Upgrade ubuntu/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.22.4-1ubuntu1.1
  6. Upgrade

    Upgrade debian/gst-plugins-bad1.0 to a version that resolves this vulnerability.

    Fixed in 1.14.4-1+deb10u5Fixed in 1.18.4-3+deb11u4Fixed in 1.22.0-4+deb12u5Fixed in 1.22.10-1Fixed in 1.24.2-3
  7. Upgrade

    Upgrade GStreamer to a version that resolves this vulnerability.

    Fixed in 1.22.7

Event History

Nov 15, 2023
Advisory Published
via ZDI·12:00 AM
Data Sourced
via ZDI·12:00 AM
DescriptionSeverityAffected Software
Nov 17, 2023
CVE Published
via Ubuntu·12:00 AM
May 3, 2024
CVE Published
via MITRE·02:14 AM
Data Sourced
via MITRE·02:14 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:16 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·03:16 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2023-44446?

CVE-2023-44446 is a vulnerability in the MXF demuxer component of the gst-plugins-bad1.0 package, which can lead to a use-after-free issue.

2

What is the severity of CVE-2023-44446?

The severity of CVE-2023-44446 is not specified in the provided information. Please refer to the references for more details.

3

Which software is affected by CVE-2023-44446?

The gst-plugins-bad1.0 package in Debian is affected by CVE-2023-44446.

4

How do I fix CVE-2023-44446?

To fix CVE-2023-44446, update to the fixed versions of the gst-plugins-bad1.0 package provided by Debian as mentioned in the remedy field of the affected software information.

5

Where can I find more information about CVE-2023-44446?

You can find more information about CVE-2023-44446 in the references provided: [link1](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-44446), [link2](https://gstreamer.freedesktop.org/security/sa-2023-0010.html), [link3](https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/5635).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203