CVE-2023-46317: High severity nic Knot Resolver vulnerability
Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical responses from servers.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/knot-resolverto a version that resolves this vulnerability.Fixed in 5.6.0-1+deb12u1Fixed in 5.7.5-1Fixed in 6.5.0-2 - Upgrade
Upgrade
Knot Resolverto a version that resolves this vulnerability.Fixed in 5.7.0
Event History
Frequently Asked Questions
What is the vulnerability ID for the Knot Resolver vulnerability?
The vulnerability ID for the Knot Resolver vulnerability is CVE-2023-46317.
What is the title of the Knot Resolver vulnerability?
The title of the Knot Resolver vulnerability is 'Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical responses from servers.'
What is the severity of the Knot Resolver vulnerability?
The severity of the Knot Resolver vulnerability is high with a severity value of 7.5.
What is the affected software for the Knot Resolver vulnerability?
The affected software for the Knot Resolver vulnerability is Nic Knot Resolver version up to and excluding 5.7.0.
How can I fix the Knot Resolver vulnerability?
To fix the Knot Resolver vulnerability, update your Nic Knot Resolver software to version 5.7.0 or later.