CVE-2023-46846: Squid: request/response smuggling in http/1.1 and icap
Description: Due to chunked decoder lenience Squid is vulnerable to Request/Response smuggling attacks when parsing HTTP/1.1 and ICAP messages
Reference: https://github.com/squid-cache/squid/security/advisories/GHSA-j83v-w3p4-5cqh
Affected versions: 2.6-6.3. Patched in 6.4.
Other sources
SQUID is vulnerable to HTTP request smuggling, caused by chunked decoder lenience, allows a remote attacker to perform Request/Response smuggling past firewall and frontend security systems.
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 4.10-1ubuntu1.8 - Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 5.7-0ubuntu0.22.04.2 - Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 5.7-1ubuntu3.1 - Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 6.1-2ubuntu1.1 - Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 6.1-2ubuntu2 - Upgrade
Upgrade
ubuntu/squidto a version that resolves this vulnerability.Fixed in 6.4 - Upgrade
Upgrade
debian/squidto a version that resolves this vulnerability.Fixed in 4.6-1+deb10u10Fixed in 4.13-10+deb11u3Fixed in 5.7-2+deb12u1Fixed in 6.9-1 - Upgrade
Upgrade
redhat/squidto a version that resolves this vulnerability.Fixed in 6.4 - Upgrade
Upgrade
Squidto a version that resolves this vulnerability.Fixed in 6.4
Event History
Frequently Asked Questions
What is CVE-2023-46846?
CVE-2023-46846 is a vulnerability in Squid that allows a remote attacker to perform HTTP request smuggling past firewall and frontend security systems.
How severe is CVE-2023-46846?
CVE-2023-46846 has a severity rating of 9.3 (Critical).
How can I fix CVE-2023-46846?
To fix CVE-2023-46846, update your Squid software to version 6.4 or later.
Which software versions are affected by CVE-2023-46846?
Squid versions up to 6.4 are affected by CVE-2023-46846.
Where can I find more information about CVE-2023-46846?
You can find more information about CVE-2023-46846 on the Redhat advisory page: [link](https://access.redhat.com/errata/RHSA-2023:6266).