First published: Mon Nov 20 2023(Updated: )
The `Embed Privacy` plugin for WordPress that prevents the loading of embedded external content is vulnerable to Stored Cross-Site Scripting via `embed_privacy_opt_out` shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 1.8.1 contains a patch for this issue.
|Affected Software||Affected Version||How to fix|
|Epiph Embed Privacy||<1.8.1|
The vulnerability ID is CVE-2023-48300.
The title of the vulnerability is 'Embed Privacy missing escaping for show_all attribute in opt-out shortcode'.
The severity of CVE-2023-48300 is medium with a severity value of 6.3.
The 'Embed Privacy' plugin for WordPress versions up to and including 1.8.0 is affected by CVE-2023-48300.
The vulnerability can be exploited through Stored Cross-Site Scripting (XSS) via the 'embed_privacy_opt_out' shortcode.