CVE-2023-49285: Denial of Service in HTTP Message Processing in Squid
Last updated 24 July 2024
Other sources
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/squidto a version that resolves this vulnerability.Fixed in 6.5 - Upgrade
Upgrade
debian/squidto a version that resolves this vulnerability.Fixed in 5.7-2+deb12u5Fixed in 5.7-2+deb12u6Fixed in 6.13-2+deb13u3Fixed in 6.13-2+deb13u4Fixed in 7.8-1 - Upgrade
Upgrade
Squidto a version that resolves this vulnerability.Fixed in 6.5
Event History
Frequently Asked Questions
What is CVE-2023-49285?
CVE-2023-49285 is a vulnerability in Squid that allows for a Denial of Service attack.
What is the severity of CVE-2023-49285?
CVE-2023-49285 has a severity rating of 8.6 (high).
How does CVE-2023-49285 affect Squid?
CVE-2023-49285 affects Squid versions 6.4 and below.
How can I fix CVE-2023-49285?
CVE-2023-49285 can be fixed by upgrading to Squid version 6.5.
Are there any workarounds for CVE-2023-49285?
There are no known workarounds for CVE-2023-49285.