CVE-2023-51781: Use After Free

Published Dec 25, 2023
·
Updated

An issue was discovered in the Linux kernel before 6.6.8. atalkioctl in net/appletalk/ddp.c has a use-after-free because of an atalkrecvmsg race condition.

Affected Software

16 affected componentsFixes available
Linux Linux kernel>2.6.12<6.6.8
Linux Linux kernel=2.6.12-rc2
Linux Linux kernel=2.6.12-rc3
Linux Linux kernel=2.6.12-rc4
Linux Linux kernel=2.6.12-rc5
Linux Linux kernel=2.6.12-rc6
Linux Linux kernel=6.7-rc1
Linux Linux kernel=6.7-rc2
Linux Linux kernel=6.7-rc3
Linux Linux kernel=6.7-rc4
Linux Linux kernel=6.7-rc5
Debian Debian Linux=10.0
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.148.1-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  2. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 6.6.8
  3. Configuration

    Ensure /etc/modprobe.d/blacklist-rare-network.conf contains the line: alias net-pf-5 off

    Linux Appletalk module alias net-pf-5 = off

Event History

Dec 25, 2023
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Jan 19, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2023-51781?

CVE-2023-51781 is classified as a high severity vulnerability due to its potential exploitation in the Linux kernel.

2

How do I fix CVE-2023-51781?

To fix CVE-2023-51781, update your Linux kernel to version 6.6.8 or later, or apply the specific patches provided by your distribution.

3

What versions of the Linux kernel are affected by CVE-2023-51781?

CVE-2023-51781 affects all Linux kernel versions prior to 6.6.8, including the 2.6.x series up to 6.7-rc5.

4

What type of vulnerability is CVE-2023-51781?

CVE-2023-51781 is a use-after-free vulnerability caused by a race condition in atalk_recvmsg within the Linux kernel.

5

Who is affected by CVE-2023-51781?

Users and systems running vulnerable versions of the Linux kernel, particularly versions between 2.6.12 and 6.6.8, are susceptible to CVE-2023-51781.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203