CVE-2023-52453: hisi_acc_vfio_pci: Update migration data pointer correctly on saving/resume

Published Feb 23, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

hisiaccvfiopci: Update migration data pointer correctly on saving/resume

When the optional PRECOPY support was added to speed up the device compatibility check, it failed to update the saving/resuming data pointers based on the fd offset. This results in migration data corruption and when the device gets started on the destination the following error is reported in some cases,

[ 478.907684] arm-smmu-v3 arm-smmu-v3.2.auto: event 0x10 received: [ 478.913691] arm-smmu-v3 arm-smmu-v3.2.auto: 0x0000310200000010 [ 478.919603] arm-smmu-v3 arm-smmu-v3.2.auto: 0x000002088000007f [ 478.925515] arm-smmu-v3 arm-smmu-v3.2.auto: 0x0000000000000000 [ 478.931425] arm-smmu-v3 arm-smmu-v3.2.auto: 0x0000000000000000 [ 478.947552] hisizip 0000:31:00.0: qmaxirresp [error status=0x1] found [ 478.955930] hisizip 0000:31:00.0: qmdbtimeout [error status=0x400] found [ 478.955944] hisizip 0000:31:00.0: qm sq doorbell timeout in function 2

Affected Software

3 affected componentsFixes available
Linux Linux kernel>=6.2<6.6.14
Linux Linux kernel>=6.7<6.7.2
debian/linux
5.10.223-15.10.234-16.1.129-16.1.135-16.12.25-16.12.27-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1

Event History

Feb 23, 2024
CVE Published
via MITRE·02:46 PM
Data Sourced
via MITRE·02:46 PM
DescriptionSeverity
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2023-52453?

CVE-2023-52453 has a high severity level due to its potential impact on the Linux kernel's migration data handling.

2

How do I fix CVE-2023-52453?

To resolve CVE-2023-52453, you should update the Linux kernel to a version that includes the fix, such as 6.6.15 or higher.

3

Which versions of the Linux kernel are affected by CVE-2023-52453?

CVE-2023-52453 affects Linux kernel versions between 6.2 and 6.6.14, as well as specific versions in the 6.7 series.

4

What type of vulnerability is CVE-2023-52453?

CVE-2023-52453 is a migration data handling vulnerability found in the Linux kernel related to device compatibility during virtual machine operations.

5

Is there a specific patch for CVE-2023-52453?

Yes, there are specific kernel patches available that address CVE-2023-52453, included in recent kernel updates.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203