CVE-2023-52507: nfc: nci: assert requested protocol is valid
In the Linux kernel, the following vulnerability has been resolved:
nfc: nci: assert requested protocol is valid
The protocol is used in a bit mask to determine if the protocol is supported. Assert the provided protocol is less than the maximum defined so it doesn't potentially perform a shift-out-of-bounds and provide a clearer error for undefined protocols vs unsupported ones.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.22-1Fixed in 6.12.25-1
Event History
Frequently Asked Questions
What is the severity of CVE-2023-52507?
CVE-2023-52507 is classified as a medium severity vulnerability in the Linux kernel.
How do I fix CVE-2023-52507?
To fix CVE-2023-52507, upgrade your Linux kernel to version 5.10.223-1, 5.10.234-1, 6.1.123-1, 6.1.128-1, 6.12.12-1, or 6.12.17-1.
Which versions of the Linux kernel are affected by CVE-2023-52507?
CVE-2023-52507 affects Linux kernel versions from 3.2 up to but not including 6.6-rc5.
What is the impact of CVE-2023-52507?
The impact of CVE-2023-52507 can lead to potential miscommunication regarding supported protocols in NFC operations.
Is there a patch available for CVE-2023-52507?
Yes, patches for CVE-2023-52507 are included in the updated versions of the Linux kernel mentioned in the remediation.