CVE-2023-52672: pipe: wakeup wr_wait after setting max_usage
In the Linux kernel, the following vulnerability has been resolved:
pipe: wakeup wrwait after setting maxusage
Commit c73be61cede5 ("pipe: Add general notification queue support") a regression was introduced that would lock up resized pipes under certain conditions. See the reproducer in [1].
The commit resizing the pipe ring size was moved to a different function, doing that moved the wakeup for pipe->wrwait before actually raising pipe->maxusage. If a pipe was full before the resize occured it would result in the wakeup never actually triggering pipewrite.
Set @maxusage and @nraccounted before waking writers if this isn't a watch queue.
[Christian Brauner <brauner@kernel.org>: rewrite to account for watch queues]
Other sources
In the Linux kernel, the following vulnerability has been resolved:
pipe: wakeup wrwait after setting maxusage
The Linux kernel CVE team has assigned CVE-2023-52672 to this issue.
Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024051729-CVE-2023-52672-f30c@gregkh/T
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.10.210 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.15.149 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.1.76 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.6.15 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.7.3 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.8
Event History
Frequently Asked Questions
What is the severity of CVE-2023-52672?
CVE-2023-52672 has been classified as a moderate severity vulnerability due to its potential to cause pipe lockups in the Linux kernel.
How do I fix CVE-2023-52672?
To mitigate CVE-2023-52672, you should upgrade to the patched versions of the Linux kernel, specifically 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.119-1, 6.12.10-1, or 6.12.11-1.
Which versions of the Linux kernel are affected by CVE-2023-52672?
CVE-2023-52672 affects multiple versions of the Linux kernel prior to the fixes, including earlier versions leading up to 6.12.11-1.
Is CVE-2023-52672 a critical vulnerability?
CVE-2023-52672 is not categorized as critical but poses risks that system administrators should address promptly.
What specific issue does CVE-2023-52672 address in the Linux kernel?
CVE-2023-52672 addresses a regression in the Linux kernel that locks up resized pipes under certain conditions.