CVE-2023-52674: ALSA: scarlett2: Add clamp() in scarlett2_mixer_ctl_put()

Published May 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ALSA: scarlett2: Add clamp() in scarlett2mixerctlput()

Ensure the value passed to scarlett2mixerctlput() is between 0 and SCARLETT2MIXERMAXVALUE so we don't attempt to access outside scarlett2mixervalues[].

Other sources

In the Linux kernel, the following vulnerability has been resolved:

ALSA: scarlett2: Add clamp() in scarlett2mixerctlput()

The Linux kernel CVE team has assigned CVE-2023-52674 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024051747-CVE-2023-52674-2aec@gregkh/T

— Red Hat

Affected Software

10 affected componentsFixes available
redhat/kernel<5.15.148
5.15.148
redhat/kernel<6.1.75
6.1.75
redhat/kernel<6.6.14
6.6.14
redhat/kernel<6.7.2
6.7.2
redhat/kernel<6.8
6.8
Linux Linux kernel>=5.4<5.15.148
Linux Linux kernel>=5.16<6.1.75
Linux Linux kernel>=6.2<6.6.14
Linux Linux kernel>=6.7<6.7.2
debian/linux<=5.10.223-1, <=5.10.234-1
6.1.129-16.1.135-16.12.25-16.12.27-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.15.148
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.75
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.14
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.7.2
  6. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8
  7. Upgrade

    Upgrade Linux kernel ALSA scarlett2 to a version that resolves this vulnerability.

    Patch CVE-2023-52674

Event History

May 17, 2024
CVE Published
via MITRE·02:24 PM
Data Sourced
via MITRE·02:24 PM
Description
May 18, 2024
Data Sourced
via Red Hat·01:39 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2023-52674?

CVE-2023-52674 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2023-52674?

To fix CVE-2023-52674, update your kernel to version 5.15.148, 6.1.75, 6.6.14, 6.7.2, 6.8, or appropriate patched versions provided by your distribution.

3

What does CVE-2023-52674 affect?

CVE-2023-52674 affects the ALSA subsystem and specifically the scarlett2 mixer control functionality in the Linux kernel.

4

When was CVE-2023-52674 disclosed?

CVE-2023-52674 was disclosed in 2023 as part of a security update for the Linux kernel.

5

What are the risks of not addressing CVE-2023-52674?

Failure to address CVE-2023-52674 could potentially allow for out-of-bounds access, leading to instability or security risks in systems utilizing affected kernel versions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203