CVE-2023-52677: riscv: Check if the code to patch lies in the exit section
In the Linux kernel, the following vulnerability has been resolved:
riscv: Check if the code to patch lies in the exit section
Otherwise we fall through to vmalloctopage() which panics since the address does not lie in the vmalloc region.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.22-1Fixed in 6.12.25-1
Event History
Frequently Asked Questions
What is the severity of CVE-2023-52677?
CVE-2023-52677 is classified as a high-severity vulnerability affecting the Linux kernel.
How do I fix CVE-2023-52677?
To fix CVE-2023-52677, users should upgrade to Linux kernel versions 6.1.123-1, 6.1.119-1, 6.12.11-1, or 6.12.12-1.
Which versions of the Linux kernel are affected by CVE-2023-52677?
CVE-2023-52677 affects Linux kernel versions up to and including 5.10.226-1.
What impact does CVE-2023-52677 have on system stability?
CVE-2023-52677 may lead to system panics if the code to patch does not lie in the proper vmalloc region.
Is CVE-2023-52677 present in the Debian Linux package?
Yes, CVE-2023-52677 affects the Debian Linux package versions prior to 5.10.227-1.