CVE-2023-52680: ALSA: scarlett2: Add missing error checks to *_ctl_get()

Published May 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ALSA: scarlett2: Add missing error checks to ctlget()

The ctlget() functions which call scarlett2update() were not checking the return value. Fix to check the return value and pass to the caller.

Other sources

In the Linux kernel, the following vulnerability has been resolved:

ALSA: scarlett2: Add missing error checks to ctlget()

The Linux kernel CVE team has assigned CVE-2023-52680 to this issue.

Upstream advisory: https://lore.kernel.org/linux-cve-announce/2024051750-CVE-2023-52680-1f4a@gregkh/T

— Red Hat

Affected Software

10 affected componentsFixes available
debian/linux<=5.10.223-1, <=5.10.234-1
6.1.129-16.1.135-16.12.25-16.12.27-1
redhat/kernel<5.15.148
5.15.148
redhat/kernel<6.1.75
6.1.75
redhat/kernel<6.6.14
6.6.14
redhat/kernel<6.7.2
6.7.2
redhat/kernel<6.8
6.8
Linux Linux kernel>=5.4<5.15.148
Linux Linux kernel>=5.16<6.1.75
Linux Linux kernel>=6.2<6.6.14
Linux Linux kernel>=6.7<6.7.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.15.148
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.75
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.14
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.7.2
  6. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.8

Event History

May 17, 2024
CVE Published
via MITRE·02:24 PM
Data Sourced
via MITRE·02:24 PM
Description
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 18, 2024
Data Sourced
via Red Hat·01:26 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2023-52680?

CVE-2023-52680 is classified with medium severity due to potential impact on the Linux kernel functionality.

2

How do I fix CVE-2023-52680?

To fix CVE-2023-52680, update your kernel to versions 5.15.148, 6.1.75, 6.6.14, 6.7.2, 6.8, or the specified versions for Debian.

3

What type of vulnerability is CVE-2023-52680?

CVE-2023-52680 is a vulnerability in the ALSA subsystem of the Linux kernel affecting error handling in certain control functions.

4

What systems are affected by CVE-2023-52680?

CVE-2023-52680 affects Red Hat kernel versions below 5.15.148, 6.1.75, 6.6.14, 6.7.2, and 6.8, as well as several Debian versions.

5

Is there a patch for CVE-2023-52680 available?

Yes, patches for CVE-2023-52680 are included in the updated kernel versions released by Red Hat and Debian.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203