CVE-2023-52818: drm/amd: Fix UBSAN array-index-out-of-bounds for SMU7
In the Linux kernel, the following vulnerability has been resolved:
drm/amd: Fix UBSAN array-index-out-of-bounds for SMU7
For pptable structs that use flexible array sizes, use flexible arrays.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.133-1Fixed in 6.12.21-1Fixed in 6.12.22-1 - Configuration
For pptable structs that use flexible array sizes, use flexible arrays.
Linux kernel drm/amd SMU7 pptable struct array declarations = flexible arrays
Event History
Frequently Asked Questions
What is the severity of CVE-2023-52818?
CVE-2023-52818 has a medium severity rating due to potential out-of-bounds access vulnerabilities in the Linux kernel.
How do I fix CVE-2023-52818?
To fix CVE-2023-52818, update your Linux kernel to a version that is 5.10.223-1 or higher.
Which versions of the Linux kernel are affected by CVE-2023-52818?
CVE-2023-52818 affects Linux kernel versions up to 4.14.331, and versions between 4.15 and 6.6.3.
What is the nature of the vulnerability described in CVE-2023-52818?
CVE-2023-52818 involves an array-index-out-of-bounds access vulnerability in the AMD Direct Rendering Manager for the Linux kernel.
Is CVE-2023-52818 a critical vulnerability?
No, CVE-2023-52818 is not classified as critical, but it poses risks that should be mitigated through kernel updates.