CVE-2023-52913: drm/i915: Fix potential context UAFs

Published Aug 21, 2024
·
Updated

drm/i915: Fix potential context UAFs

Other sources

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=5.8.11<5.9
Linux Linux kernel>=5.10<6.1.7
Linux Linux kernel=6.2-rc1
Linux Linux kernel=6.2-rc2
Linux Linux kernel=6.2-rc3
debian/linux<=5.10.223-1, <=5.10.234-1
6.1.129-16.1.135-16.12.25-16.12.27-1
Microsoft cbl2 kernel 5.15.182.1-1
Microsoft cbl2 kernel 5.15.176.3-1
Microsoft cbl2 kernel 5.15.182.1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1

Event History

Aug 21, 2024
CVE Published
via MITRE·06:10 AM
Data Sourced
via MITRE·06:10 AM
DescriptionSeverity
Data Sourced
via NVD·07:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 4, 2025
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2023-52913?

CVE-2023-52913 has been classified as a high severity vulnerability due to potential use-after-free issues in the Linux kernel.

2

How do I fix CVE-2023-52913?

To fix CVE-2023-52913, update your Linux kernel to a version that includes the security patches addressing this vulnerability.

3

What versions of the Linux kernel are affected by CVE-2023-52913?

CVE-2023-52913 affects Linux kernel versions from 5.8.11 to 5.9 and 5.10 to 6.1.7, along with various 6.2 release candidates.

4

What kind of vulnerability is CVE-2023-52913?

CVE-2023-52913 is a context use-after-free vulnerability within the DRM subsystem of the Linux kernel.

5

Can CVE-2023-52913 be exploited remotely?

CVE-2023-52913 may allow an attacker to exploit the vulnerability locally, potentially leading to privilege escalation or system instability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203