CVE-2023-5545: Moodle Exposure of Sensitive Information to an Unauthorized Actor vulnerability
H5P metadata automatically populated the author with the user's username, which could be sensitive information.
Other sources
Moodle Exposure of Sensitive Information to an Unauthorized Actor vulnerability
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.0-rc2 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.2.3 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.1.6 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.11.17 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.9.24
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2023-5545.
What is the severity level of CVE-2023-5545?
The severity level of CVE-2023-5545 is medium with a score of 5.3.
How does the vulnerability affect Moodle?
The vulnerability affects Moodle versions up to 4.2.3, 4.1.6, 4.0.11, 3.11.17, and 3.9.24.
What is the potential impact of this vulnerability?
The vulnerability can cause an information leak by automatically populating the H5P author name with the user's username.
How can I fix CVE-2023-5545?
To fix CVE-2023-5545, you need to update Moodle to version 4.2.3, 4.1.6, 4.0.11, 3.11.17, or 3.9.24.