CVE-2023-5547: Moodle Cross-site Scripting vulnerability
Moodle Cross-site Scripting vulnerability
Other sources
The course upload preview contained an XSS risk for users uploading unsafe data.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.0-rc2 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.2.3 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.1.6 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.11.17 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.9.24
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2023-5547.
What is the severity of CVE-2023-5547?
The severity of CVE-2023-5547 is medium.
How does CVE-2023-5547 affect Moodle?
CVE-2023-5547 affects Moodle versions up to and including 4.2.3.
How can I fix CVE-2023-5547?
To fix CVE-2023-5547, update Moodle to version 4.2.4 or higher.
Where can I find more information about CVE-2023-5547?
More information about CVE-2023-5547 can be found at the following references: [Link 1](http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-79455), [Link 2](https://bugzilla.redhat.com/show_bug.cgi?id=2243447), [Link 3](https://moodle.org/mod/forum/discuss.php?d=451588).