CVE-2023-5550: Moodle Code Injection vulnerability
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.9.24 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.11.17 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.1.6 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.2.3 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.0-rc2 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.2.3 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.1.6 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.11.17 - Upgrade
Upgrade
redhat/moodleto a version that resolves this vulnerability.Fixed in 3.9.24
Event History
Frequently Asked Questions
What is CVE-2023-5550?
CVE-2023-5550 is a vulnerability that allows remote code execution in misconfigured shared hosting environments.
What is the severity of CVE-2023-5550?
CVE-2023-5550 has a severity rating of 9.8 (critical).
How can CVE-2023-5550 be exploited?
CVE-2023-5550 can be exploited through a local file include vulnerability in a misconfigured shared hosting environment.
Which versions of Moodle are affected by CVE-2023-5550?
Versions up to and including Moodle 4.2.3 are affected by CVE-2023-5550.
How can I fix CVE-2023-5550?
To fix CVE-2023-5550, update Moodle to version 4.2.4 or later.