CVE-2023-5561: WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

Published Oct 16, 2023
·
Updated

The Popup Builder WordPress plugin through 4.1.15 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilteredhtml capability is disallowed (for example in multisite setup).

Other sources

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

Affected Software

18 affected componentsFixes available
WordPress WordPress>=4.7<4.7.27
WordPress WordPress>=4.8<4.8.23
WordPress WordPress>=4.9<4.9.24
WordPress WordPress>=5.0<5.0.20
WordPress WordPress>=5.1<5.1.17
WordPress WordPress>=5.2<5.2.19
WordPress WordPress>=5.3<5.3.16
WordPress WordPress>=5.4<5.4.14
WordPress WordPress>=5.5<5.5.13
WordPress WordPress>=5.6<5.6.12
WordPress WordPress>=5.7<5.7.10
WordPress WordPress>=5.8<5.8.8
WordPress WordPress>=5.9<5.9.8
WordPress WordPress>=6.0<6.0.6
WordPress WordPress>=6.1<6.1.4
WordPress WordPress>=6.2<6.2.3
WordPress WordPress>=6.3<6.3.2
debian/wordpress
6.1.9+dfsg1-0+deb12u16.8.7+dfsg1-0+deb13u16.8.12+dfsg1-0+deb13u17.1.4+dfsg1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/wordpress to a version that resolves this vulnerability.

    Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1
  2. Upgrade

    Upgrade WordPress to a version that resolves this vulnerability.

    Fixed in 6.3.2

Event History

Oct 16, 2023
CVE Published
via MITRE·07:39 PM
Data Sourced
via MITRE·07:39 PM
DescriptionWeakness
Dec 13, 2023
Exploit Published
via GitHub·04:43 PM

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2023-5561?

The severity of CVE-2023-5561 is medium with a CVSS score of 5.3.

2

What is the affected software for CVE-2023-5561?

The Popup Builder WordPress plugin versions 4.1.15 and earlier are affected.

3

How can a high privilege user exploit CVE-2023-5561?

A high privilege user such as an admin can exploit CVE-2023-5561 to perform Stored Cross-Site Scripting attacks.

4

Can CVE-2023-5561 be exploited even if unfiltered_html capability is disallowed?

Yes, CVE-2023-5561 can be exploited even when the unfiltered_html capability is disallowed.

5

Is there a fix for CVE-2023-5561?

Yes, make sure to update the Popup Builder WordPress plugin to version 4.1.16 or later to fix CVE-2023-5561.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203